summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2013-08-23 16:58:29 +0400
committerAnton Leontiev2015-02-15 07:48:01 +0300
commit9cda73ff5c0b6a98f9c061ee3668688d5a679185 (patch)
treef4b203c3085ff5b136a5db6e4cf682d83c8182c9
downloadaur-9cda73ff5c0b6a98f9c061ee3668688d5a679185.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD32
-rw-r--r--PKGBUILD.tt32
4 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a2fec62baf31
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = perl-class-insideout
+ pkgdesc = Perl module for safe and simple inside-out objects construction
+ pkgver = 1.13
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Class-InsideOut
+ arch = any
+ license = Apache
+ depends = perl
+ depends = perl-class-isa
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/D/DA/DAGOLDEN/Class-InsideOut-1.13.tar.gz
+ md5sums = 5b760b74a7c36cd7a5a1f3aa614318da
+
+pkgname = perl-class-insideout
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e6b6b4b8077d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.lz
+src/
+pkg/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6e1333dfa929
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# CPAN Name : Class::InsideOut
+# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname=perl-class-insideout
+pkgver=1.13
+pkgrel=1
+pkgdesc='Perl module for safe and simple inside-out objects construction'
+arch=('any')
+url="http://search.cpan.org/dist/Class-InsideOut"
+license=('Apache')
+depends=("perl" "perl-class-isa")
+options=(!emptydirs)
+source=(http://search.cpan.org/CPAN/authors/id/D/DA/DAGOLDEN/Class-InsideOut-1.13.tar.gz)
+md5sums=('5b760b74a7c36cd7a5a1f3aa614318da')
+
+build() {
+ cd "$srcdir/Class-InsideOut-1.13"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$srcdir/Class-InsideOut-1.13"
+ make test
+}
+
+package() {
+ cd "$srcdir/Class-InsideOut-1.13"
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
new file mode 100644
index 000000000000..7de72758ed29
--- /dev/null
+++ b/PKGBUILD.tt
@@ -0,0 +1,32 @@
+# CPAN Name : Class::InsideOut
+# Contributor: [% packager %]
+# Generator : CPANPLUS::Dist::Arch [% version %]
+
+pkgname=[% pkgname %]
+pkgver=[% pkgver %]
+pkgrel=[% pkgrel %]
+pkgdesc='Perl module for safe and simple inside-out objects construction'
+arch=('any')
+url="[% url %]"
+license=('Apache')
+depends=("perl" "perl-class-isa")
+options=(!emptydirs)
+source=([% source %])
+md5sums=('[% md5sums %]')
+
+build() {
+ cd "$srcdir/[% distdir %]"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$srcdir/[% distdir %]"
+ make test
+}
+
+package() {
+ cd "$srcdir/[% distdir %]"
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}