summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortrizen2016-07-19 05:43:11 +0300
committertrizen2016-07-19 05:43:11 +0300
commitfa67dd2fb91bfb5fb6b93070f503564c745c808d (patch)
tree2feb55df4fd54f69d64d3924288b5f11df176185
downloadaur-fa67dd2fb91bfb5fb6b93070f503564c745c808d.tar.gz
new file: .SRCINFO
new file: PKGBUILD
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD50
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f9e3d5aa03b1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-class-multimethods
+ pkgdesc = Support multimethods and function overloading in Perl
+ pkgver = 1.70
+ pkgrel = 1
+ url = https://metacpan.org/release/Class-Multimethods
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/D/DC/DCONWAY/Class-Multimethods-1.70.tar.gz
+ md5sums = 5fdc79daa81b102b956b1a61531fd6a7
+ sha512sums = 41a6e40e7cebd1f4273a8d410dda0a7fda1d235ed86902a18505274c7b7d9170921a02b5a4328c0a0cb0820455a3376b8e78f453b38af13f184c2f8908253b44
+
+pkgname = perl-class-multimethods
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0237ac61af66
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: Trizen <echo dHJpemVueEBnbWFpbC5jb20K | base64 -d>
+# Generator : CPANPLUS::Dist::Arch 1.32
+
+pkgname='perl-class-multimethods'
+pkgver='1.70'
+pkgrel='1'
+pkgdesc="Support multimethods and function overloading in Perl"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='https://metacpan.org/release/Class-Multimethods'
+source=('http://search.cpan.org/CPAN/authors/id/D/DC/DCONWAY/Class-Multimethods-1.70.tar.gz')
+md5sums=('5fdc79daa81b102b956b1a61531fd6a7')
+sha512sums=('41a6e40e7cebd1f4273a8d410dda0a7fda1d235ed86902a18505274c7b7d9170921a02b5a4328c0a0cb0820455a3376b8e78f453b38af13f184c2f8908253b44')
+_distdir="Class-Multimethods-1.70"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: