summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcamb2022-09-28 11:49:56 +0100
committercamb2022-09-28 11:49:56 +0100
commit83059a471708ab98b16a213a21e68e2efe672493 (patch)
treecd1e23f2c82e5fbfe73674d85e9d8f73d7e8e21a
downloadaur-83059a471708ab98b16a213a21e68e2efe672493.tar.gz
Initial commit v0.08
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD39
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e67a1a432c3f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = perl-cli-osprey
+ pkgdesc = Module to assist in writing commandline applications with M* OO modules.
+ pkgver = 0.08
+ pkgrel = 1
+ url = https://metacpan.org/release/CLI-Osprey
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ checkdepends = perl>=5.12
+ checkdepends = perl-test-lib>=0
+ depends = perl>=5.12
+ depends = perl-getopt-long-descriptive
+ depends = perl-module-runtime
+ depends = perl-moo
+ depends = perl-path-tiny
+ options = !emptydirs
+ options = purge
+ source = http://search.cpan.org/CPAN/authors/id/A/AR/ARODLAND/CLI-Osprey-0.08.tar.gz
+ md5sums = faacf1400414bc57e551c4ce700523b1
+ sha256sums = f7480523dbdf2c2b53789c06a8bd91cf6579bb8cc5678e72ea8a1faaab30d19a
+ sha512sums = f643cc4981d3140da3bc713e9a12c36fd5b7bcaff493e9f462de59f8dcee18a66fa7be3154fd9dbcf4a5bc63cdf8d3a3896e2efc96dcb4862c7319e38a5de240
+
+pkgname = perl-cli-osprey
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b64cceef56f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: camb
+
+pkgname=perl-cli-osprey
+pkgver=0.08
+pkgrel=1
+pkgdesc='Module to assist in writing commandline applications with M* OO modules.'
+_dist='CLI-Osprey'
+arch=('any')
+url="https://metacpan.org/release/$_dist"
+license=('GPL' 'PerlArtistic')
+# Author doesn't say minimum perl version but currently Getopt::Long::Descriptive needs 5.12
+depends=('perl>=5.12' 'perl-getopt-long-descriptive' 'perl-module-runtime' 'perl-moo' 'perl-path-tiny')
+checkdepends=('perl>=5.12' 'perl-test-lib>=0')
+options=('!emptydirs' purge)
+source=("http://search.cpan.org/CPAN/authors/id/A/AR/ARODLAND/$_dist-$pkgver.tar.gz")
+md5sums=('faacf1400414bc57e551c4ce700523b1')
+sha256sums=('f7480523dbdf2c2b53789c06a8bd91cf6579bb8cc5678e72ea8a1faaab30d19a')
+sha512sums=('f643cc4981d3140da3bc713e9a12c36fd5b7bcaff493e9f462de59f8dcee18a66fa7be3154fd9dbcf4a5bc63cdf8d3a3896e2efc96dcb4862c7319e38a5de240')
+
+build() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 MODULEBUILDRC=/dev/null
+ /usr/bin/perl Build.PL
+ ./Build
+}
+
+check() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ ./Build test
+}
+
+package() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ ./Build install --installdirs=vendor --destdir="$pkgdir"
+}