summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2017-11-17 20:30:25 +0100
committerPiotr Rogoża2017-11-17 20:30:25 +0100
commit30fe4bbfe9fc47c57552ee2d80116cd0d544cb6a (patch)
tree6c67f037c42669b5012343dca8ffc3ea4d725aa0
parenta23542050eca2415c6bfa65ef2cba1f41221a9d7 (diff)
downloadaur-30fe4bbfe9fc47c57552ee2d80116cd0d544cb6a.tar.gz
Upgraded to 1.07
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD36
2 files changed, 17 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 915fb365d7f7..3441f584db63 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,17 @@
+# Generated by mksrcinfo v8
+# Fri Nov 17 19:30:19 UTC 2017
pkgbase = perl-clone-pp
pkgdesc = Clone::PP - Recursively copy Perl datatypes
- pkgver = 1.06
+ pkgver = 1.07
pkgrel = 1
url = http://search.cpan.org/dist/Clone-PP/
arch = any
license = GPL
license = PerlArtistic
- depends = perl>=5.10.0
+ depends = perl
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/N/NE/NEILB/Clone-PP-1.06.tar.gz
- sha256sums = 4ccf74174a83543787946e5c06a0b3c56f4b3bd29e21632f74d11ade30b9b7e7
+ source = http://search.cpan.org/CPAN/authors/id/N/NE/NEILB/Clone-PP-1.07.tar.gz
+ sha256sums = bf85e109b7d9a10677db82fa65c1720ae95499a49cbb676d4b3d1b183786b395
pkgname = perl-clone-pp
diff --git a/PKGBUILD b/PKGBUILD
index e8c0537c90d4..1f744d4aca0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,7 @@
-# Maintainer: Piotr Rogoża <rogoza dot piotr at gmail dot com>
-# Contributor: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+# Maintainer: dracorp aka Piotr Rogoza <piotr.r.public at gmail.com>
pkgname=perl-clone-pp
-pkgver=1.06
+pkgver=1.07
pkgrel=1
_author=N/NE/NEILB
_perlmod=Clone-PP
@@ -11,55 +10,42 @@ arch=('any')
url="http://search.cpan.org/dist/Clone-PP/"
license=('GPL' 'PerlArtistic')
groups=()
-depends=('perl>=5.10.0')
+depends=(perl)
makedepends=()
provides=()
conflicts=()
replaces=()
options=(!emptydirs)
source=("http://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz")
-sha256sums=('4ccf74174a83543787946e5c06a0b3c56f4b3bd29e21632f74d11ade30b9b7e7')
+sha256sums=('bf85e109b7d9a10677db82fa65c1720ae95499a49cbb676d4b3d1b183786b395')
+unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps MODULEBUILDRC=/dev/null
build(){
cd "$srcdir"/$_perlmod-$pkgver
- # Setting these env variables overwrites any command-line-options we don't want...
- export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
- PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
- MODULEBUILDRC=/dev/null
-
- # If using Makefile.PL
if [ -r Makefile.PL ]; then
/usr/bin/perl Makefile.PL
make
- # If using Build.PL
elif [ -r Build.PL ]; then
- /usr/bin/perl Build.PL
- perl Build
+ perl Build.PL
+ ./Build
fi
}
check(){
cd "$srcdir"/$_perlmod-$pkgver
- # If using Makefile.PL
if [ -r Makefile.PL ]; then
make test
- # If using Build.PL
elif [ -r Build.PL ]; then
- perl Build test
+ ./Build test
fi
}
package(){
cd "$srcdir"/$_perlmod-$pkgver
- # If using Makefile.PL
if [ -r Makefile.PL ]; then
- make install
- # If using Build.PL
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
elif [ -r Build.PL ]; then
- perl Build install
+ ./Build install --installdirs=vendor --destdir="$pkgdir"
fi
-
- # remove perllocal.pod and .packlist
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}