summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2015-06-14 16:23:29 +0200
committerPiotr Rogoża2015-06-14 16:23:29 +0200
commita23542050eca2415c6bfa65ef2cba1f41221a9d7 (patch)
treea2882b47bf34fbb154204b9766e7810cbab44385
downloadaur-a23542050eca2415c6bfa65ef2cba1f41221a9d7.tar.gz
Initial import
-rw-r--r--.AURINFO14
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD65
3 files changed, 94 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..5d9138fcb77c
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,14 @@
+pkgbase = perl-clone-pp
+ pkgdesc = Clone::PP - Recursively copy Perl datatypes
+ pkgver = 1.06
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Clone-PP/
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl>=5.10.0
+ source = http://search.cpan.org/CPAN/authors/id/N/NE/NEILB/Clone-PP-1.06.tar.gz
+ options = !emptydirs
+
+pkgname = perl-clone-pp
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..915fb365d7f7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = perl-clone-pp
+ pkgdesc = Clone::PP - Recursively copy Perl datatypes
+ pkgver = 1.06
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Clone-PP/
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl>=5.10.0
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/N/NE/NEILB/Clone-PP-1.06.tar.gz
+ sha256sums = 4ccf74174a83543787946e5c06a0b3c56f4b3bd29e21632f74d11ade30b9b7e7
+
+pkgname = perl-clone-pp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e8c0537c90d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+# Contributor: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+
+pkgname=perl-clone-pp
+pkgver=1.06
+pkgrel=1
+_author=N/NE/NEILB
+_perlmod=Clone-PP
+pkgdesc='Clone::PP - Recursively copy Perl datatypes'
+arch=('any')
+url="http://search.cpan.org/dist/Clone-PP/"
+license=('GPL' 'PerlArtistic')
+groups=()
+depends=('perl>=5.10.0')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+options=(!emptydirs)
+source=("http://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz")
+sha256sums=('4ccf74174a83543787946e5c06a0b3c56f4b3bd29e21632f74d11ade30b9b7e7')
+build(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # Setting these env variables overwrites any command-line-options we don't want...
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ /usr/bin/perl Makefile.PL
+ make
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ /usr/bin/perl Build.PL
+ perl Build
+ fi
+}
+check(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make test
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build test
+ fi
+}
+package(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make install
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build install
+ fi
+
+ # remove perllocal.pod and .packlist
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}