summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 14:28:55 -0600
committerJohn D Jones III2015-06-16 14:28:55 -0600
commitb31b5c51b4ef578b904bbed7be2a7edb4f9f296e (patch)
treeefaa0b4fbd763d1790ccf890928d233607df1874
downloadaur-b31b5c51b4ef578b904bbed7be2a7edb4f9f296e.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD50
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..edcde1e7c26d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-config-crontab
+ pkgdesc = Read/Write Vixie compatible crontab(5) files
+ pkgver = 1.33
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Config-Crontab
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/S/SC/SCOTTW/Config-Crontab-1.33.tar.gz
+ md5sums = d53d47477a7d044b0cf6d54e21aa0215
+ sha512sums = 2545449a30cf575c89bb8e45d199a98042f5cb3bb91117ddb3d8f9c9d1b6e609fde96eca06d3866c3f12a3d438b093df34a7e87a68056bd05c58892dfcf2927a
+
+pkgname = perl-config-crontab
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6cac62532359
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname='perl-config-crontab'
+pkgver='1.33'
+pkgrel='1'
+pkgdesc="Read/Write Vixie compatible crontab(5) files"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='http://search.cpan.org/dist/Config-Crontab'
+source=('http://search.cpan.org/CPAN/authors/id/S/SC/SCOTTW/Config-Crontab-1.33.tar.gz')
+md5sums=('d53d47477a7d044b0cf6d54e21aa0215')
+sha512sums=('2545449a30cf575c89bb8e45d199a98042f5cb3bb91117ddb3d8f9c9d1b6e609fde96eca06d3866c3f12a3d438b093df34a7e87a68056bd05c58892dfcf2927a')
+_distdir="Config-Crontab-1.33"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: