summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-07-16 21:43:50 -0600
committerBrian Bidulock2015-07-16 21:43:50 -0600
commit388450c89ee2bfb65dbef9f0c8f0ac06464c9c9f (patch)
tree2d120d3e5f0ddadab7c4f2bc5a7db630d648502d
downloadaur-388450c89ee2bfb65dbef9f0c8f0ac06464c9c9f.tar.gz
initial version
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD32
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e17b1a6b1b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = perl-config-general
+ pkgdesc = Config::General - Generic Config Module
+ pkgver = 2.56
+ pkgrel = 2
+ url = http://search.cpan.org/dist/Config-General
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ options = !emptydirs
+ source = http://cpan.org/modules/by-module/Config/Config-General-2.56.tar.gz
+ sha512sums = 0439d690e58fb30cafd18e3c51fb1c6226cb20017fcd260959ad0210006d0e98a32a939d314b384e5c62871c0a59400a678099e3d703d9e2ed859de20292de9a
+
+pkgname = perl-config-general
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ed38719d14d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Jason St. John <jstjohn .. purdue . edu>
+
+_perlmod=Config-General
+_modnamespace=Config
+pkgname=perl-config-general
+pkgver=2.56
+pkgrel=2
+pkgdesc="Config::General - Generic Config Module"
+arch=('any')
+url="http://search.cpan.org/dist/${_perlmod}"
+license=('GPL' 'PerlArtistic')
+options=('!emptydirs')
+source=("http://cpan.org/modules/by-module/${_modnamespace}/${_perlmod}-${pkgver}.tar.gz")
+sha512sums=('0439d690e58fb30cafd18e3c51fb1c6226cb20017fcd260959ad0210006d0e98a32a939d314b384e5c62871c0a59400a678099e3d703d9e2ed859de20292de9a')
+
+build() {
+ cd "${_perlmod}-${pkgver}"
+
+ # Install module in vendor directories.
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "${_perlmod}-${pkgver}"
+ make test
+}
+
+package() {
+ cd "${_perlmod}-${pkgver}"
+ make install DESTDIR="${pkgdir}"
+}