summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2015-06-14 15:27:43 +0200
committerPiotr Rogoża2015-06-14 15:27:43 +0200
commitb18698541e6462b63ef8b72a54993a8e207b597f (patch)
treed5b85bd7558d09a5948fd8fcfc223df7cf8bd336
downloadaur-b18698541e6462b63ef8b72a54993a8e207b597f.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD75
2 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4c269fe604d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = perl-configreader-simple
+ pkgdesc = ConfigReader::Simple - simple configuration file parser
+ pkgver = 1.28
+ pkgrel = 3
+ url = http://search.cpan.org/dist/ConfigReader-Simple/
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl>=5.10.0
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/B/BD/BDFOY/ConfigReader-Simple-1.28.tar.gz
+ md5sums = 2b6b97fdc4c2082c15d9c4c0300747cb
+
+pkgname = perl-configreader-simple
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d1db2d62c52
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,75 @@
+# Maintainer: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+# Contributor: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+# vim:set ts=2 sw=2 et ft=sh tw=100: expandtab
+
+pkgname=perl-configreader-simple
+pkgver=1.28
+_author=B/BD/BDFOY
+_perlmod=ConfigReader-Simple
+pkgrel=3
+pkgdesc='ConfigReader::Simple - simple configuration file parser'
+arch=('any')
+url="http://search.cpan.org/dist/ConfigReader-Simple/"
+license=('GPL' 'PerlArtistic')
+groups=()
+depends=('perl>=5.10.0')
+makedepends=()
+#optdepends=(
+# 'perl-test-output: for testing packages'
+# 'perl-test-warn: for testing packages'
+# 'perl-test-prereq: for testing packages'
+#)
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("http://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz")
+noextract=()
+
+build(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # Setting these env variables overwrites any command-line-options we don't want...
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ /usr/bin/perl Makefile.PL
+ make
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ /usr/bin/perl Build.PL
+ perl Build
+ fi
+}
+check(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make test
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build test
+ fi
+}
+package(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make install
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build install
+ fi
+
+ # remove perllocal.pod and .packlist
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+md5sums=('2b6b97fdc4c2082c15d9c4c0300747cb')