summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryardenac2013-05-22 02:13:51 -0700
committeryardenac2013-05-22 02:13:51 -0700
commit49c2a41ea366a91692d68a5b34f69aaa2a558f30 (patch)
tree6b8ec9640fb8041ee240d21fc3467bfe7d95f5ee
downloadaur-49c2a41ea366a91692d68a5b34f69aaa2a558f30.tar.gz
import perl-convert-uulib (orphaned from 2011-06-21)
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD34
-rw-r--r--perl-convert-uulib.install17
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..62ce8168789f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = perl-convert-uulib
+ pkgdesc = Perl interface to the uulib library (a.k.a. uudeview/uuenview).
+ pkgver = 1.4
+ pkgrel = 1
+ url = http://search.cpan.org/~mlehmann/Convert-UUlib/
+ install = perl-convert-uulib.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = Artistic
+ depends = perl>=5.8.4
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/M/ML/MLEHMANN/Convert-UUlib-1.4.tar.gz
+ md5sums = a6486df1d9ce319406fb9d5a610da759
+
+pkgname = perl-convert-uulib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f5d57efe78e2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Techlivezheng <techlivezheng [at] gmail [dot] com>
+# Contributor: Filip S. Adamsen <fsa [at] fsadev [dot] com>
+# Contributor: David Zaragoza <david@zaragoza.com.ve>
+# Contributor: Piotr Beling <qwak@w8.pl>
+# Contributor: Wael Nasreddine <wael@phoenixlinux.org>
+# Contributor: Guillermo A. Amaral <me@guillermoamaral.com> (thewonka)
+# Contributor: Chih-mao Chen <pkmx.tw@gmail.com>
+
+pkgname='perl-convert-uulib'
+pkgver='1.4'
+pkgrel='1'
+pkgdesc='Perl interface to the uulib library (a.k.a. uudeview/uuenview).'
+url='http://search.cpan.org/~mlehmann/Convert-UUlib/'
+arch=('i686' 'x86_64')
+license=('GPL' 'Artistic')
+depends=('perl>=5.8.4')
+options=(!emptydirs)
+install="${pkgname}.install"
+source=("http://search.cpan.org/CPAN/authors/id/M/ML/MLEHMANN/Convert-UUlib-${pkgver}.tar.gz")
+
+build(){
+ cd "${srcdir}/Convert-UUlib-${pkgver}"
+
+ # install module in vendor directories.
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make install DESTDIR=${pkgdir} || return 1
+
+ # remove perllocal.pod and .packlist
+ find ${pkgdir} -name perllocal.pod -delete
+ find ${pkgdir} -name .packlist -delete
+}
+
+md5sums=('a6486df1d9ce319406fb9d5a610da759')
diff --git a/perl-convert-uulib.install b/perl-convert-uulib.install
new file mode 100644
index 000000000000..e9b08afa059b
--- /dev/null
+++ b/perl-convert-uulib.install
@@ -0,0 +1,17 @@
+post_install()
+{
+ echo -n "module test... "
+
+ perl -mConvert::UUlib -e "exit 0;" 2> /dev/null && echo 'pass.' || echo 'fail.'
+}
+
+post_upgrade()
+{
+ post_install
+}
+
+op=$1
+
+shift
+
+$op $*