summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryardenac2013-05-22 02:59:00 -0700
committeryardenac2013-05-22 08:16:13 -0700
commit991171f7ead4788eeaec655f59f56eef4b822c75 (patch)
tree1f8119cb77edae89f2a4ce8eb89361af212cbbc2
parent49c2a41ea366a91692d68a5b34f69aaa2a558f30 (diff)
downloadaur-991171f7ead4788eeaec655f59f56eef4b822c75.tar.gz
perl-convert-uulib: clean up, fix build errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD19
-rw-r--r--install (renamed from perl-convert-uulib.install)13
3 files changed, 16 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62ce8168789f..9977d87b34a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = perl-convert-uulib
pkgdesc = Perl interface to the uulib library (a.k.a. uudeview/uuenview).
pkgver = 1.4
- pkgrel = 1
+ pkgrel = 2
url = http://search.cpan.org/~mlehmann/Convert-UUlib/
- install = perl-convert-uulib.install
+ install = install
arch = i686
arch = x86_64
license = GPL
diff --git a/PKGBUILD b/PKGBUILD
index f5d57efe78e2..e98d4b8f849d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,27 +8,32 @@
pkgname='perl-convert-uulib'
pkgver='1.4'
-pkgrel='1'
+pkgrel='2'
pkgdesc='Perl interface to the uulib library (a.k.a. uudeview/uuenview).'
url='http://search.cpan.org/~mlehmann/Convert-UUlib/'
arch=('i686' 'x86_64')
license=('GPL' 'Artistic')
depends=('perl>=5.8.4')
options=(!emptydirs)
-install="${pkgname}.install"
+install="install"
source=("http://search.cpan.org/CPAN/authors/id/M/ML/MLEHMANN/Convert-UUlib-${pkgver}.tar.gz")
+md5sums=('a6486df1d9ce319406fb9d5a610da759')
build(){
cd "${srcdir}/Convert-UUlib-${pkgver}"
+ unset CPPFLAGS
+
# install module in vendor directories.
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make || return 1
- make install DESTDIR=${pkgdir} || return 1
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+package() {
+ cd "${srcdir}/Convert-UUlib-${pkgver}"
+
+ make install DESTDIR=${pkgdir}
# remove perllocal.pod and .packlist
find ${pkgdir} -name perllocal.pod -delete
find ${pkgdir} -name .packlist -delete
}
-
-md5sums=('a6486df1d9ce319406fb9d5a610da759')
diff --git a/perl-convert-uulib.install b/install
index e9b08afa059b..41c5d667b446 100644
--- a/perl-convert-uulib.install
+++ b/install
@@ -1,17 +1,8 @@
-post_install()
-{
+post_install() {
echo -n "module test... "
-
perl -mConvert::UUlib -e "exit 0;" 2> /dev/null && echo 'pass.' || echo 'fail.'
}
-post_upgrade()
-{
+post_upgrade() {
post_install
}
-
-op=$1
-
-shift
-
-$op $*