summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 14:31:35 -0600
committerJohn D Jones III2015-06-16 14:31:35 -0600
commit34000d2037d21320831c7502cb9df646e7dea4e0 (patch)
treea0b5dc22aec2b63fb69687194358b2d88f9f190d
downloadaur-34000d2037d21320831c7502cb9df646e7dea4e0.tar.gz
Initial import
-rw-r--r--.AURINFO17
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD50
3 files changed, 86 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..a9304553547f
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,17 @@
+pkgbase = perl-cpan-outdated
+ pkgdesc = detect outdated CPAN modules in your environment.
+ pkgver = 0.28
+ pkgrel = 2
+ url = http://search.mcpan.org/dist/cpan-outdated
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl-cpan-distnameinfo>=0.1
+ depends = perl-libwww
+ depends = perl-local-lib>=1.006008
+ depends = perl>=5.8.1
+ source = http://search.mcpan.org/CPAN/authors/id/T/TO/TOKUHIROM/cpan-outdated-0.28.tar.gz
+ options = !emptydirs
+
+pkgname = perl-cpan-outdated
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c8de5eb051fc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = perl-cpan-outdated
+ pkgdesc = detect outdated CPAN modules in your environment.
+ pkgver = 0.28
+ pkgrel = 2
+ url = http://search.mcpan.org/dist/cpan-outdated
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl-cpan-distnameinfo>=0.1
+ depends = perl-libwww
+ depends = perl-local-lib>=1.006008
+ depends = perl>=5.8.1
+ options = !emptydirs
+ source = http://search.mcpan.org/CPAN/authors/id/T/TO/TOKUHIROM/cpan-outdated-0.28.tar.gz
+ md5sums = 3f0dbeb84a9c854dc31b090f09880f84
+ sha512sums = fa011be0393f1c22685b4ad2ff26a71a3b2ba045fdf489ce40e716dfd6610d718fbcb0769567493b1895232c993ef49ce10fb242a37ad04999aaefe0aa223e59
+
+pkgname = perl-cpan-outdated
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d63c63af89a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+# Generator : CPANPLUS::Dist::Arch 1.28
+
+pkgname='perl-cpan-outdated'
+pkgver='0.28'
+pkgrel='2'
+pkgdesc="detect outdated CPAN modules in your environment."
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-cpan-distnameinfo>=0.1' 'perl-libwww' 'perl-local-lib>=1.006008' 'perl>=5.8.1')
+makedepends=()
+url='http://search.mcpan.org/dist/cpan-outdated'
+source=('http://search.mcpan.org/CPAN/authors/id/T/TO/TOKUHIROM/cpan-outdated-0.28.tar.gz')
+md5sums=('3f0dbeb84a9c854dc31b090f09880f84')
+sha512sums=('fa011be0393f1c22685b4ad2ff26a71a3b2ba045fdf489ce40e716dfd6610d718fbcb0769567493b1895232c993ef49ce10fb242a37ad04999aaefe0aa223e59')
+_distdir="cpan-outdated-0.28"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Build.PL
+ /usr/bin/perl Build
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ /usr/bin/perl Build test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Build install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: