summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2018-09-08 12:03:14 +0200
committerhaawda2018-09-08 12:03:14 +0200
commit373304033d014fcf45e0070b3d79c38b491064de (patch)
tree9ef015ba80a09d24d7e34296081a66feef0299a5
parent3b8b50462394f322b7ee31c2f4d15e2fad359cf7 (diff)
downloadaur-373304033d014fcf45e0070b3d79c38b491064de.tar.gz
adopted and updated
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD29
2 files changed, 13 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 74781001015a..4296d29a9d19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Thu Dec 22 23:00:50 UTC 2016
pkgbase = perl-cpanel-json-xs
pkgdesc = cPanel fork of JSON::XS, fast and correct serializing
- pkgver = 3.0225
+ pkgver = 4.06
pkgrel = 1
url = https://metacpan.org/release/Cpanel-JSON-XS
arch = i686
@@ -11,9 +9,8 @@ pkgbase = perl-cpanel-json-xs
license = GPL
depends = perl
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/R/RU/RURBAN/Cpanel-JSON-XS-3.0225.tar.gz
- md5sums = 6be52ff9c55adcb531a464291aad4bd3
- sha512sums = 5e43c6116cc0b59c6bfabcc7a701c19ca1a29749aa9df299fa3cd6a55b3672353e995dc896f9f716880bfaa078a0ba1617c5c3d8f70ecdf02c8d4aa297caf0c6
+ source = http://search.cpan.org/CPAN/authors/id/R/RU/RURBAN/Cpanel-JSON-XS-4.06.tar.gz
+ sha512sums = df765265c23982a6c5eb80d16d9c9e3b3ab9f0b34aa130df8da084936aa2b7e9f4b362466948925df7be9c448892eef93017cf1fa7be7f640b62c83493829cec
pkgname = perl-cpanel-json-xs
diff --git a/PKGBUILD b/PKGBUILD
index 1079e29eae76..06dd67377d49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,17 @@
-# Contributor: John D Jones III AKA jnbek <jnbek1972 -_AT_- g m a i l -_Dot_- com>
-# Generator : CPANPLUS::Dist::Arch 1.32
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
-pkgname='perl-cpanel-json-xs'
-pkgver='3.0225'
-pkgrel='1'
+pkgname=perl-cpanel-json-xs
+pkgver=4.06
+pkgrel=1
pkgdesc="cPanel fork of JSON::XS, fast and correct serializing"
arch=('i686' 'x86_64')
license=('PerlArtistic' 'GPL')
options=('!emptydirs')
depends=('perl')
-makedepends=()
url='https://metacpan.org/release/Cpanel-JSON-XS'
-source=('http://search.cpan.org/CPAN/authors/id/R/RU/RURBAN/Cpanel-JSON-XS-3.0225.tar.gz')
-md5sums=('6be52ff9c55adcb531a464291aad4bd3')
-sha512sums=('5e43c6116cc0b59c6bfabcc7a701c19ca1a29749aa9df299fa3cd6a55b3672353e995dc896f9f716880bfaa078a0ba1617c5c3d8f70ecdf02c8d4aa297caf0c6')
-_distdir="Cpanel-JSON-XS-3.0225"
+source=("http://search.cpan.org/CPAN/authors/id/R/RU/RURBAN/Cpanel-JSON-XS-$pkgver.tar.gz")
+sha512sums=('df765265c23982a6c5eb80d16d9c9e3b3ab9f0b34aa130df8da084936aa2b7e9f4b362466948925df7be9c448892eef93017cf1fa7be7f640b62c83493829cec')
+_distdir="Cpanel-JSON-XS-$pkgver"
build() {
( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
@@ -23,28 +20,22 @@ build() {
PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
MODULEBUILDRC=/dev/null
- cd "$srcdir/$_distdir"
+ cd "$_distdir"
/usr/bin/perl Makefile.PL
make
)
}
check() {
- cd "$srcdir/$_distdir"
+ cd "$_distdir"
( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
make test
)
}
package() {
- cd "$srcdir/$_distdir"
+ cd "$_distdir"
make install
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}
-
-# Local Variables:
-# mode: shell-script
-# sh-basic-offset: 2
-# End:
-# vim:set ts=2 sw=2 et: