summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 14:31:46 -0600
committerJohn D Jones III2015-06-16 14:31:46 -0600
commite8f11c0f2943c49d004b4978643bc6aeb3f1bf0d (patch)
tree7af181e191a383f10f50fb4192c248bc6074d179
downloadaur-e8f11c0f2943c49d004b4978643bc6aeb3f1bf0d.tar.gz
Initial import
-rw-r--r--.AURINFO15
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD50
3 files changed, 82 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..3a94739cca05
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,15 @@
+pkgbase = perl-cpanplus-dist-build
+ pkgdesc = CPANPLUS plugin to install packages that use Build.PL
+ pkgver = 0.78
+ pkgrel = 1
+ url = http://search.mcpan.org/dist/CPANPLUS-Dist-Build
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl-cpanplus>=0.84
+ depends = perl
+ source = http://search.mcpan.org/CPAN/authors/id/B/BI/BINGOS/CPANPLUS-Dist-Build-0.78.tar.gz
+ options = !emptydirs
+
+pkgname = perl-cpanplus-dist-build
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f9c4914f8e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = perl-cpanplus-dist-build
+ pkgdesc = CPANPLUS plugin to install packages that use Build.PL
+ pkgver = 0.78
+ pkgrel = 1
+ url = http://search.mcpan.org/dist/CPANPLUS-Dist-Build
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl-cpanplus>=0.84
+ depends = perl
+ options = !emptydirs
+ source = http://search.mcpan.org/CPAN/authors/id/B/BI/BINGOS/CPANPLUS-Dist-Build-0.78.tar.gz
+ md5sums = 9a40202a68fa13125b2adffc057cc053
+ sha512sums = 733abc212ea6ec506bc90c43e3860ee08f3a0a4b5908311f9c68c119d6ac2dc62876d2f2f468bd23dfaf7bb336ebd73a4c01e462ffaceff0802aee935aab75df
+
+pkgname = perl-cpanplus-dist-build
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..24faeaa742b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+# Generator : CPANPLUS::Dist::Arch 1.28
+
+pkgname='perl-cpanplus-dist-build'
+pkgver='0.78'
+pkgrel='1'
+pkgdesc="CPANPLUS plugin to install packages that use Build.PL"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-cpanplus>=0.84' 'perl')
+makedepends=()
+url='http://search.mcpan.org/dist/CPANPLUS-Dist-Build'
+source=('http://search.mcpan.org/CPAN/authors/id/B/BI/BINGOS/CPANPLUS-Dist-Build-0.78.tar.gz')
+md5sums=('9a40202a68fa13125b2adffc057cc053')
+sha512sums=('733abc212ea6ec506bc90c43e3860ee08f3a0a4b5908311f9c68c119d6ac2dc62876d2f2f468bd23dfaf7bb336ebd73a4c01e462ffaceff0802aee935aab75df')
+_distdir="CPANPLUS-Dist-Build-0.78"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: