summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiquel Lionel2021-05-31 22:50:28 +0100
committerMiquel Lionel2021-05-31 22:50:28 +0100
commit370b683f0e348feef0c133dc5a2c45f79d71cc9c (patch)
tree3d0e9f5a86a839063a3e7581ce01ca5b6a62317e
parentd3779d51f333e6a28a18f8fe4897a218f20deb79 (diff)
downloadaur-370b683f0e348feef0c133dc5a2c45f79d71cc9c.tar.gz
added some indents for readability
-rw-r--r--PKGBUILD41
1 files changed, 21 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 29b2fdcee2a9..c8012a23bd4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,17 +22,18 @@ build() {
make
else
- _dir=$(find $srcdir -maxdepth 2 -type f -name 'Build.PL')
- if [ ! -z "$_dir" ]; then
- cd $(dirname "$_dir")
- PERL_MM_USE_DEFAULT=1 perl Build.PL INSTALLDIRS=vendor
- ./Build
+ _dir=$(find $srcdir -maxdepth 2 -type f -name 'Build.PL')
+ if [ ! -z "$_dir" ]; then
+ cd $(dirname "$_dir")
+ PERL_MM_USE_DEFAULT=1 perl Build.PL INSTALLDIRS=vendor
+ ./Build
- else
- echo "error: failed to detect build method for $pkgname"
- echo "you may be able to fix this by editing the PKGBUILD"
- return 1
- fi fi
+ else
+ echo "error: failed to detect build method for $pkgname"
+ echo "you may be able to fix this by editing the PKGBUILD"
+ return 1
+ fi
+ fi
}
@@ -42,18 +43,18 @@ echo "pkg starts here"
if [ ! -z "$_dir" ]; then
cd $(dirname "$_dir")
make install DESTDIR="${pkgdir}"
-
else
- _dir=$(find $srcdir -maxdepth 2 -type f -name 'Build.PL')
- if [ ! -z "$_dir" ]; then
- cd $(dirname "$_dir")
- ./Build install destdir=${pkgdir}
+ _dir=$(find $srcdir -maxdepth 2 -type f -name 'Build.PL')
+ if [ ! -z "$_dir" ]; then
+ cd $(dirname "$_dir")
+ ./Build install destdir=${pkgdir}
- else
- echo "error: failed to detect build method for $pkgname"
- echo "you may be able to fix this by editing the PKGBUILD"
- return 1
- fi fi
+ else
+ echo "error: failed to detect build method for $pkgname"
+ echo "you may be able to fix this by editing the PKGBUILD"
+ return 1
+ fi
+ fi
# remove perllocal.pod and .packlist
find ${pkgdir} -name perllocal.pod -delete