summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDirk Langer2019-01-21 08:13:51 +0100
committerDirk Langer2019-01-21 08:13:51 +0100
commitc810b9c9a77f3182ee3214467d79e59c3bb915f0 (patch)
tree463c3c0c8bb1d2992b4be32145c9316513905d5a
downloadaur-c810b9c9a77f3182ee3214467d79e59c3bb915f0.tar.gz
version 3.14.10
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD46
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..54726625e16f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = perl-css-sass
+ pkgdesc = Compile .scss files using libsass
+ pkgver = 3.4.10
+ pkgrel = 1
+ url = http://search.cpan.org/~OCBNET/CSS-Sass-3.4.10/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = PerlArtistic
+ makedepends = perl-extutils-cppguess
+ depends = perl>=5.i10.0
+ depends = perl-linux-inotify2
+ options = !emptydirs
+ source = https://cpan.metacpan.org/authors/id/C/CH/CHAMAS/CSS-Sass-3.4.10.tar.gz
+ md5sums = d407da50fba8d5c583fc4ae418f52523
+ sha512sums = 742c4d6d0d0dc5ace30313146f57772f3ff0ef0c83d1eab8e54969d12f84bf9392f8875a6985f4b959f20a550db0d517fe30234a5c686b0d7716c8a7d97b5979
+
+pkgname = perl-css-sass
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..97aa8f17eea7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Ordoban <dirk.langer@vvovgonik.de>
+_author=OCBNET
+_perlmod=CSS-Sass
+pkgname=perl-css-sass
+pkgver=3.4.10
+pkgrel=1
+pkgdesc="Compile .scss files using libsass"
+arch=('i686'
+ 'x86_64')
+url="http://search.cpan.org/~$_author/$_perlmod-$pkgver/"
+license=('GPL' 'PerlArtistic')
+depends=('perl>=5.i10.0'
+ 'perl-linux-inotify2')
+makedepends=('perl-extutils-cppguess')
+options=(!emptydirs)
+source=(https://cpan.metacpan.org/authors/id/C/CH/CHAMAS/${_perlmod}-${pkgver}.tar.gz)
+md5sums=('d407da50fba8d5c583fc4ae418f52523')
+sha512sums=('742c4d6d0d0dc5ace30313146f57772f3ff0ef0c83d1eab8e54969d12f84bf9392f8875a6985f4b959f20a550db0d517fe30234a5c686b0d7716c8a7d97b5979')
+
+build() {
+ cd "$srcdir/$_perlmod-$pkgver"
+
+ # Install module in vendor directories.
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ PERL5LIB="" PERL_LOCAL_LIB_ROOT="" \
+ MODULEBUILDRC=/dev/null
+ perl Makefile.PL
+ make
+}
+
+check() {
+ cd "$srcdir/$_perlmod-$pkgver"
+ make test
+}
+
+package() {
+ cd "$srcdir/$_perlmod-$pkgver"
+ make install DESTDIR="$pkgdir/"
+
+ # remove perllocal.pod and .packlist
+ find "$pkgdir" \( -name .packlist -o -name perllocal.pod \) -delete
+}
+
+# vim:set ts=2 sw=2 et: