summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 14:36:44 -0600
committerJohn D Jones III2015-06-16 14:36:44 -0600
commitab7ad3abecb752ac886b132af6fe4d62c629c537 (patch)
tree467fdcafe4fd42033d5c5c699f9d9e487b1e35d0
downloadaur-ab7ad3abecb752ac886b132af6fe4d62c629c537.tar.gz
Initial import
-rw-r--r--.AURINFO14
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD50
3 files changed, 80 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..ac7d5b206746
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,14 @@
+pkgbase = perl-data-dumper-concise
+ pkgdesc = Less indentation and newlines plus sub deparsing
+ pkgver = 2.022
+ pkgrel = 1
+ url = http://search.mcpan.org/dist/Data-Dumper-Concise
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ source = http://search.mcpan.org/CPAN/authors/id/F/FR/FREW/Data-Dumper-Concise-2.022.tar.gz
+ options = !emptydirs
+
+pkgname = perl-data-dumper-concise
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..041c0860a4f6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-data-dumper-concise
+ pkgdesc = Less indentation and newlines plus sub deparsing
+ pkgver = 2.022
+ pkgrel = 1
+ url = http://search.mcpan.org/dist/Data-Dumper-Concise
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ options = !emptydirs
+ source = http://search.mcpan.org/CPAN/authors/id/F/FR/FREW/Data-Dumper-Concise-2.022.tar.gz
+ md5sums = 416882cd86114e7cea9a429ae97fb5a6
+ sha512sums = a3b17d740571db3d1968438830af5aee912f671dbc3692b2708ecb9301bc7770025d48202c3414a8e50cc2b48050f8b27b2a2c9b62d01681f0ce06888c37bd40
+
+pkgname = perl-data-dumper-concise
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43595a5de961
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+# Generator : CPANPLUS::Dist::Arch 1.28
+
+pkgname='perl-data-dumper-concise'
+pkgver='2.022'
+pkgrel='1'
+pkgdesc="Less indentation and newlines plus sub deparsing"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='http://search.mcpan.org/dist/Data-Dumper-Concise'
+source=('http://search.mcpan.org/CPAN/authors/id/F/FR/FREW/Data-Dumper-Concise-2.022.tar.gz')
+md5sums=('416882cd86114e7cea9a429ae97fb5a6')
+sha512sums=('a3b17d740571db3d1968438830af5aee912f671dbc3692b2708ecb9301bc7770025d48202c3414a8e50cc2b48050f8b27b2a2c9b62d01681f0ce06888c37bd40')
+_distdir="Data-Dumper-Concise-2.022"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: