summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergej Pupykin2015-06-13 00:48:31 +0300
committerSergej Pupykin2015-06-13 00:48:31 +0300
commitcabe0b9b35e7c70d37cdbf3c3558ee039ab5af9e (patch)
tree881ac19e097b08a3a0560b87f819a4244e38a6b0
downloadaur-perl-data-dumper-simple.tar.gz
migrate to aur4
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD38
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6ea015b956c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = perl-data-dumper-simple
+ pkgdesc = Easily dump variables with names
+ pkgver = 0.110.0
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Data-Dumper-Simple/
+ arch = any
+ license = perl
+ depends = perl-filter-simple
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/O/OV/OVID/Data-Dumper-Simple-0.11.tar.gz
+ md5sums = 0a3e67bf5bb6f2f39116bb92632631df
+
+pkgname = perl-data-dumper-simple
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..423d10f8ae46
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+pkgname=perl-data-dumper-simple
+pkgver=0.110.0
+pkgrel=1
+pkgdesc="Easily dump variables with names"
+arch=('any')
+url="http://search.cpan.org/dist/Data-Dumper-Simple/"
+license=('perl')
+depends=('perl-filter-simple')
+options=(!emptydirs)
+source=('http://search.cpan.org/CPAN/authors/id/O/OV/OVID/Data-Dumper-Simple-0.11.tar.gz')
+md5sums=('0a3e67bf5bb6f2f39116bb92632631df')
+
+build() {
+ _dir=$(find $srcdir -maxdepth 2 -type f -name 'Makefile.PL')
+ if [ ! -z "$_dir" ]; then
+ cd $(dirname "$_dir")
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+ make install DESTDIR="${pkgdir}"
+
+ else
+ _dir=$(find $srcdir -maxdepth 2 -type f -name 'Build.PL')
+ if [ ! -z "$_dir" ]; then
+ cd $(dirname "$_dir")
+ PERL_MM_USE_DEFAULT=1 perl Build.PL INSTALLDIRS=vendor
+ ./Build
+ ./Build install destdir=${pkgdir}
+
+ else
+ echo "error: failed to detect build method for $pkgname"
+ echo "you may be able to fix this by editing the PKGBUILD"
+ return 1
+ fi fi
+
+ # remove perllocal.pod and .packlist
+ find ${pkgdir} -name perllocal.pod -delete
+ find ${pkgdir} -name .packlist -delete
+}