summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Aranguren2019-12-16 17:31:15 +1100
committerLuis Aranguren2019-12-16 17:31:15 +1100
commit75ad52e3e732a4a92b039e3d3b89ee5b06b787c7 (patch)
tree7f11e36a6770a7d3d317f12b3b799d301b16060d
downloadaur-75ad52e3e732a4a92b039e3d3b89ee5b06b787c7.tar.gz
0.013
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD44
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..526f33f7ed62
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = perl-data-float
+ pkgdesc = Contains the Data::Float module, native floating point numerical data type
+ pkgver = 0.013
+ pkgrel = 1
+ url = https://metacpan.org/release/Data-Float
+ arch = x86_64
+ license = PerlArtistic
+ license = GPL
+ makedepends = perl-module-build
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/Z/ZE/ZEFRAM/Data-Float-0.013.tar.gz
+ md5sums = 58356ac67e6693311cc6c77f2022183d
+ sha512sums = 7e3be7843df30e581bd8937fde226ac6f24100206a376e1dbed2d4699c95d3f39a25cd1485f5871c46adba88d2fb1899efcd326f908797cdc985ec713cd9a90f
+
+pkgname = perl-data-float
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf14f102e1f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Luis Aranguren <pizzaman@hotmail.com>
+
+pkgname='perl-data-float'
+_dist='Data-Float'
+pkgver='0.013'
+pkgrel='1'
+pkgdesc="Contains the Data::Float module, native floating point numerical data type"
+arch=('x86_64')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=('perl-module-build')
+url="https://metacpan.org/release/$_dist"
+source=("http://search.cpan.org/CPAN/authors/id/Z/ZE/ZEFRAM/$_dist-$pkgver.tar.gz")
+md5sums=('58356ac67e6693311cc6c77f2022183d')
+sha512sums=('7e3be7843df30e581bd8937fde226ac6f24100206a376e1dbed2d4699c95d3f39a25cd1485f5871c46adba88d2fb1899efcd326f908797cdc985ec713cd9a90f')
+_distdir="$_dist-$pkgver"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Build.PL
+ ./Build
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ ./Build test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ ./Build install --installdirs=vendor --destdir="$pkgdir"
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}