aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Göbel2015-10-19 20:20:23 +0200
committerStefan Göbel2015-10-19 20:20:23 +0200
commit833956be245beea5a616e96854cb9ebd2c376ea0 (patch)
treefe35f705bb2b08aa3007c0bb9405eab7bd564db5
downloadaur-833956be245beea5a616e96854cb9ebd2c376ea0.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD46
-rw-r--r--README4
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..88bc93672dda
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-data-rmap
+ pkgdesc = Recursive map, apply a block to a data structure.
+ pkgver = 0.64
+ pkgrel = 1
+ url = https://metacpan.org/release/Data-Rmap
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ checkdepends = perl-test-exception
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/B/BO/BOWMANBS/Data-Rmap-0.64.tar.gz
+ md5sums = 112c9e8b813259a4700815ca66342a78
+
+pkgname = perl-data-rmap
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf40e18497b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Stefan Göbel <aur —at— subtype —dot— de>
+
+pkgname='perl-data-rmap'
+_module='Data-Rmap'
+_author='B/BO/BOWMANBS'
+pkgver='0.64'
+pkgrel='1'
+pkgdesc='Recursive map, apply a block to a data structure.'
+arch=('any')
+url="https://metacpan.org/release/$_module"
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+checkdepends=('perl-test-exception')
+source=("http://search.cpan.org/CPAN/authors/id/$_author/$_module-$pkgver.tar.gz")
+md5sums=('112c9e8b813259a4700815ca66342a78')
+
+build() {
+ (
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT='1' PERL_AUTOINSTALL='--skipdeps'
+ cd "$_module-$pkgver"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ (
+ cd "$_module-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT='1'
+ make test
+ )
+}
+
+package() {
+ (
+ cd "$_module-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install INSTALLDIRS='vendor' DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ )
+}
+
+#:indentSize=3:tabSize=3:noTabs=true:mode=shellscript:maxLineLen=87: \ No newline at end of file
diff --git a/README b/README
new file mode 100644
index 000000000000..b96d576ea089
--- /dev/null
+++ b/README
@@ -0,0 +1,4 @@
+This repository contains the PKGBUILD to create the «perl-data-rmap»
+package for the Perl module Data::Rmap for Arch Linux.
+
+See https://aur.archlinux.org/packages/perl-data-rmap/. \ No newline at end of file