summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoritz Bunkus2019-03-29 15:04:02 +0100
committerMoritz Bunkus2019-03-29 15:04:02 +0100
commit2373280374974ff31c0129e6e44dce2ca2eb0217 (patch)
treec3f890e05d80d7124f5a9fa4d4ee96d97327071f
downloadaur-perl-datetime-event-cron.tar.gz
initial packaging
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD45
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4f12084b6de
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Fri Mar 29 14:03:55 UTC 2019
+pkgbase = perl-datetime-event-cron
+ pkgdesc = DateTime extension for generating recurrence sets from crontab lines and files
+ pkgver = 0.09
+ pkgrel = 1
+ url = https://metacpan.org/pod/DateTime::Event::Cron
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl-datetime
+ depends = perl-datetime-set
+ depends = perl-set-crontab
+ options = !emptydirs
+ source = https://cpan.metacpan.org/authors/id/M/MS/MSISK/DateTime-Event-Cron-0.09.tar.gz
+ sha512sums = c2614d57424ab11f9921dbe5e4c724a3977c0f57ea4ba4fa754087f369f465e8a723ab10843095310d6631da6ba48a98a38a715316b3e4b5cbff5030eb6f24d4
+
+pkgname = perl-datetime-event-cron
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..23661bfaefd2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Moritz Bunkus <moritz@bunkus.org>
+
+pkgname=perl-datetime-event-cron
+pkgver='0.09'
+pkgrel='1'
+pkgdesc="DateTime extension for generating recurrence sets from crontab lines and files"
+arch=("any")
+license=('GPL' 'PerlArtistic')
+url="https://metacpan.org/pod/DateTime::Event::Cron"
+options=(!emptydirs)
+depends=('perl-datetime' 'perl-datetime-set' 'perl-set-crontab')
+source=("https://cpan.metacpan.org/authors/id/M/MS/MSISK/DateTime-Event-Cron-${pkgver}.tar.gz")
+sha512sums=('c2614d57424ab11f9921dbe5e4c724a3977c0f57ea4ba4fa754087f369f465e8a723ab10843095310d6631da6ba48a98a38a715316b3e4b5cbff5030eb6f24d4')
+
+prepare_environment() {
+ export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+ cd "${srcdir}/DateTime-Event-Cron-${pkgver}"
+}
+
+build() {
+ prepare_environment
+ /usr/bin/perl Makefile.PL
+ make
+}
+
+check() {
+ prepare_environment
+ make test
+}
+
+package() {
+ prepare_environment
+ make install
+ find "$pkgdir" "(" -name .packlist -o -name perllocal.pod ")" -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: