summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Komolov2015-06-08 12:11:39 +0300
committerAnton Komolov2015-06-08 12:11:39 +0300
commit418758f6e8a8fe524ba21a8d155a4c8afa6a0398 (patch)
tree8de6ad93910bcbaa19a71fcd585efc71ccecfeb9
downloadaur-418758f6e8a8fe524ba21a8d155a4c8afa6a0398.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..655d04d9b4af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-dbix-contextualfetch
+ pkgdesc = Add contextual fetches to DBI
+ pkgver = 1.03
+ pkgrel = 1
+ url = http://search.cpan.org/~tmtm/DBIx-ContextualFetch-1.03/lib/DBIx/ContextualFetch.pm
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl>=5.10.0
+ depends = perl-dbi
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/T/TM/TMTM/DBIx-ContextualFetch-1.03.tar.gz
+ md5sums = 20a78432ae26b266216b7b30ff7941c3
+
+pkgname = perl-dbix-contextualfetch
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..267e7976e450
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Ben Webb <bjwebb67 at googlemail dot com>
+pkgname=perl-dbix-contextualfetch
+pkgver=1.03
+pkgrel=1
+pkgdesc="Add contextual fetches to DBI"
+arch=(any)
+url="http://search.cpan.org/~tmtm/DBIx-ContextualFetch-1.03/lib/DBIx/ContextualFetch.pm"
+license=('GPL' 'PerlArtistic')
+depends=('perl>=5.10.0' 'perl-dbi')
+options=(!emptydirs)
+source=(http://search.cpan.org/CPAN/authors/id/T/TM/TMTM/DBIx-ContextualFetch-$pkgver.tar.gz)
+md5sums=('20a78432ae26b266216b7b30ff7941c3')
+
+build() {
+ cd "$srcdir/DBIx-ContextualFetch-$pkgver"
+
+ # install module in vendor directories.
+ perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make || return 1
+ make install DESTDIR=${pkgdir} || return 1
+
+ # remove perllocal.pod and .packlist
+ find "$pkgdir" -name perllocal.pod -delete
+ find "$pkgdir" -name .packlist -delete
+}