summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2017-09-06 22:10:34 +0200
committerPiotr Rogoża2017-09-06 22:10:34 +0200
commitb5307e3201109afefad14cc12e938b1d72052721 (patch)
treebb0ae0c1dae04b51fafdf2a6325d6aeabd65d5de
parentcffd321f8ddf83c71111db91a62318030956a28c (diff)
downloadaur-b5307e3201109afefad14cc12e938b1d72052721.tar.gz
Fixed PKGBUILD
-rw-r--r--PKGBUILD24
1 files changed, 4 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6542ac72327c..733ec351f856 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,30 +23,14 @@ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps MODULEBUILDRC=/dev/null
build(){
cd "$srcdir"/$_perlmod-$pkgver
-
- if [ -f Makefile.PL ]; then
- perl Makefile.PL
- make
- else
- perl Build.PL
- ./Build
- fi
+ perl Makefile.PL
+ make
}
check(){
cd "$srcdir"/$_perlmod-$pkgver
-
- if [ -f Makefile.PL ]; then
- make test
- else
- ./Build test
- fi
+ make test
}
package(){
cd "$srcdir"/$_perlmod-$pkgver
-
- if [ -f Makefile.PL ]; then
- make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
- else
- ./Build install installdirs=vendor destdir="$pkgdir"
- fi
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
}