summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2017-06-08 18:52:48 +0200
committerPiotr Rogoża2017-06-08 18:52:48 +0200
commitf40ffe82fde0782a2b6197f20c2ee078c650f40c (patch)
treeaf107e2735b6f89e911b6f308f3288d7d2d45480
parent42b523738bd62e0d4246f4f5358cf3dd5a13014c (diff)
downloadaur-f40ffe82fde0782a2b6197f20c2ee078c650f40c.tar.gz
pkgrel has been raised to rebuilt with new Perl version
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD57
2 files changed, 22 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 73697fc13ada..4587028b00ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Thu Jun 8 16:52:40 UTC 2017
pkgbase = perl-devel-fastprof
pkgdesc = Devel::FastProf - "fast" perl per-line profiler
pkgver = 0.08
- pkgrel = 3
+ pkgrel = 4
url = http://search.cpan.org/dist/Devel-FastProf/
arch = i686
arch = x86_64
@@ -12,7 +14,7 @@ pkgbase = perl-devel-fastprof
provides = perl-devel-fastprof-reader
options = !emptydirs
source = http://search.cpan.org/CPAN/authors/id/S/SA/SALVA/Devel-FastProf-0.08.tar.gz
- md5sums = f8185d084e0323b96ad69fc24775aa94
+ sha256sums = 8811020f4404b1ad12d513afa2ee134493ab254ceba585fa7d4e11047cfc5d98
pkgname = perl-devel-fastprof
diff --git a/PKGBUILD b/PKGBUILD
index e268c1572b4e..2771d58abbd3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,73 +1,52 @@
-# Maintainer: Piotr Rogoża <rogoza dot piotr at gmail dot com>
-# Contributor: Piotr Rogoża <rogoza dot piotr at gmail dot com>
-# vim:set ts=2 sw=2 et ft=sh tw=100: expandtab
+# Maintainer: dracorp aka Piotr Rogoza <piotr.r.public at gmail.com>
_author=S/SA/SALVA
_perlmod=Devel-FastProf
pkgname=perl-devel-fastprof
pkgver=0.08
-pkgrel=3
+pkgrel=4
pkgdesc='Devel::FastProf - "fast" perl per-line profiler'
arch=('i686' 'x86_64')
url='http://search.cpan.org/dist/Devel-FastProf/'
license=('GPL' 'PerlArtistic')
-groups=()
depends=(
perl-sort-key
perl-time-hires
)
optdepends=()
provides=(perl-devel-fastprof-reader)
-conflicts=()
-replaces=()
-backup=()
options=(!emptydirs)
-install=
source=("http://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz")
-noextract=()
+sha256sums=('8811020f4404b1ad12d513afa2ee134493ab254ceba585fa7d4e11047cfc5d98')
+unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps MODULEBUILDRC=/dev/null
build(){
cd "$srcdir"/$_perlmod-$pkgver
-
- # Setting these env variables overwrites any command-line-options we don't want...
- export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
- PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
- PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
- MODULEBUILDRC=/dev/null
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- /usr/bin/perl Makefile.PL
+ if [ -f Makefile.PL ]; then
+ perl Makefile.PL
make
- # If using Build.PL
- elif [ -r Build.PL ]; then
- /usr/bin/perl Build.PL
- perl Build
+ else
+ perl Build.PL
+ ./Build
fi
}
check(){
cd "$srcdir"/$_perlmod-$pkgver
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
+ if [ -f Makefile.PL ]; then
make test
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build test
+ else
+ ./Build test
fi
}
package(){
cd "$srcdir"/$_perlmod-$pkgver
-
- # If using Makefile.PL
- if [ -r Makefile.PL ]; then
- make install
- # If using Build.PL
- elif [ -r Build.PL ]; then
- perl Build install
- fi
- # remove perllocal.pod and .packlist
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ if [ -f Makefile.PL ]; then
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+ else
+ ./Build install installdirs=vendor destdir="$pkgdir"
+ fi
}
-md5sums=('f8185d084e0323b96ad69fc24775aa94')