summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 14:47:04 -0600
committerJohn D Jones III2015-06-16 14:47:04 -0600
commit62cc96b72fc5d4ab90dffb256e2c6ce03db87c92 (patch)
treebbb6803030c6e6919da1b7a2a158dc613032a99a
downloadaur-62cc96b72fc5d4ab90dffb256e2c6ce03db87c92.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD50
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0186039ea8a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = perl-digest-jhash
+ pkgdesc = Perl extension for 32 bit Jenkins Hashing Algorithm
+ pkgver = 0.07
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Digest-JHash
+ arch = i686
+ arch = x86_64
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/S/SH/SHLOMIF/Digest-JHash-0.07.tar.gz
+ md5sums = 273adb11b5c4701dc43273d82ab26dd9
+ sha512sums = b3509771c01036cccef8ca38b7371dd18912d02c0305a199d8d982e77590357f227cb5fe361960e6992cfca70ed0cc3dd97274ca6d433b00e68bd4838ac1798d
+
+pkgname = perl-digest-jhash
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..096a4feb04e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname='perl-digest-jhash'
+pkgver='0.07'
+pkgrel='1'
+pkgdesc="Perl extension for 32 bit Jenkins Hashing Algorithm"
+arch=('i686' 'x86_64')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='http://search.cpan.org/dist/Digest-JHash'
+source=('http://search.cpan.org/CPAN/authors/id/S/SH/SHLOMIF/Digest-JHash-0.07.tar.gz')
+md5sums=('273adb11b5c4701dc43273d82ab26dd9')
+sha512sums=('b3509771c01036cccef8ca38b7371dd18912d02c0305a199d8d982e77590357f227cb5fe361960e6992cfca70ed0cc3dd97274ca6d433b00e68bd4838ac1798d')
+_distdir="Digest-JHash-0.07"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: