summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 14:47:23 -0600
committerJohn D Jones III2015-06-16 14:47:23 -0600
commit4b7c8b177047b7063697221ccc0e69c292665d8e (patch)
treefb367b8309a2f0ba95e6bca2641e110469c1c22c
downloadaur-perl-digest-luffa.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD50
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b58267ad0a2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = perl-digest-luffa
+ pkgdesc = Perl interface to the Luffa digest algorithm
+ pkgver = 0.04
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Digest-Luffa
+ arch = i686
+ arch = x86_64
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/G/GR/GRAY/Digest-Luffa-0.04.tar.gz
+ md5sums = fd2f8cb89035d5ffc23893845c8a81e7
+ sha512sums = cb3ece0cfcd54a9c98567de3ee08165f2b5c21c9629df4fcf2c69595eba2b2e04550c01dac7b71a702ac9f8561866f2e0a27c8326feb288326766fcce2268472
+
+pkgname = perl-digest-luffa
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..710a97d03fec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname='perl-digest-luffa'
+pkgver='0.04'
+pkgrel='1'
+pkgdesc="Perl interface to the Luffa digest algorithm"
+arch=('i686' 'x86_64')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='http://search.cpan.org/dist/Digest-Luffa'
+source=('http://search.cpan.org/CPAN/authors/id/G/GR/GRAY/Digest-Luffa-0.04.tar.gz')
+md5sums=('fd2f8cb89035d5ffc23893845c8a81e7')
+sha512sums=('cb3ece0cfcd54a9c98567de3ee08165f2b5c21c9629df4fcf2c69595eba2b2e04550c01dac7b71a702ac9f8561866f2e0a27c8326feb288326766fcce2268472')
+_distdir="Digest-Luffa-0.04"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: