summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 14:52:59 -0600
committerJohn D Jones III2015-06-16 14:52:59 -0600
commitd9339848342bf9b7ba23330a3487f81b9d58ee43 (patch)
treeecca1eb082d384bf902a99a9b8ee0c03247deeed
downloadaur-d9339848342bf9b7ba23330a3487f81b9d58ee43.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD51
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a2ef375f2ce4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = perl-expect
+ pkgdesc = automate interactions with command line programs that expose a text terminal interface.
+ pkgver = 1.32
+ pkgrel = 1
+ url = http://search.mcpan.org/dist/Expect
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ checkdepends = perl-test-exception>=0.32
+ depends = perl-io-tty
+ options = !emptydirs
+ source = http://search.mcpan.org/CPAN/authors/id/S/SZ/SZABGAB/Expect-1.32.tar.gz
+ md5sums = f71527a34d57f601d5047ad9aa98e4e4
+ sha512sums = 0281d1662a902b99b5131c017b50b0456c3461c176bf4485b4bb383cab009973605514256540c5ddc2e274b5dd92ece5555719f5527d3fb8c35e83f8dc038147
+
+pkgname = perl-expect
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e788cc2121ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Contributor: John D Jones III <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+# Generator : CPANPLUS::Dist::Arch 1.29
+
+pkgname='perl-expect'
+pkgver='1.32'
+pkgrel='1'
+pkgdesc="automate interactions with command line programs that expose a text terminal interface."
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-io-tty')
+makedepends=()
+checkdepends=('perl-test-exception>=0.32')
+url='http://search.mcpan.org/dist/Expect'
+source=('http://search.mcpan.org/CPAN/authors/id/S/SZ/SZABGAB/Expect-1.32.tar.gz')
+md5sums=('f71527a34d57f601d5047ad9aa98e4e4')
+sha512sums=('0281d1662a902b99b5131c017b50b0456c3461c176bf4485b4bb383cab009973605514256540c5ddc2e274b5dd92ece5555719f5527d3fb8c35e83f8dc038147')
+_distdir="Expect-1.32"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: