summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2020-03-09 20:16:32 +0300
committerAnton Leontiev2020-03-09 20:16:54 +0300
commita0b46652d7dda2d645305da417ae3d3110f5cda6 (patch)
treef87c642bf9957ac9d362640d091228920d088642
parentdd647f8e737c032495348df6f23419d0395ac9d8 (diff)
downloadaur-a0b46652d7dda2d645305da417ae3d3110f5cda6.tar.gz
Update to v1.24
This commit also fixes command to remove .packlist and perllocal.pod.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
-rw-r--r--PKGBUILD.tt6
3 files changed, 16 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ec06a59c12b..45ffa0918072 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
-# Generated by mksrcinfo v8
-# Sun Mar 5 16:58:26 UTC 2017
pkgbase = perl-extutils-f77
pkgdesc = Perl module providing simple interface to F77 libraries
- pkgver = 1.20
+ pkgver = 1.24
pkgrel = 1
url = https://metacpan.org/release/ExtUtils-F77
arch = any
license = PerlArtistic
license = GPL
- depends = perl
+ depends = perl-file-which
depends = gcc-fortran
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/C/CH/CHM/ExtUtils-F77-1.20.tar.gz
- md5sums = df37ee4070908e55d038b2d26d27ef50
+ source = http://search.cpan.org/CPAN/authors/id/K/KG/KGB/ExtUtils-F77-1.24.tar.gz
+ md5sums = 575fd322322c605718142bc6c4db034a
pkgname = perl-extutils-f77
diff --git a/PKGBUILD b/PKGBUILD
index f5f11b6096ec..1589f6ed7275 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,16 @@
# Generator : CPANPLUS::Dist::Arch 1.32
pkgname=perl-extutils-f77
-pkgver=1.20
+pkgver=1.24
pkgrel=1
pkgdesc='Perl module providing simple interface to F77 libraries'
arch=('any')
url='https://metacpan.org/release/ExtUtils-F77'
license=('PerlArtistic' 'GPL')
-depends=('perl' 'gcc-fortran')
-source=(http://search.cpan.org/CPAN/authors/id/C/CH/CHM/ExtUtils-F77-1.20.tar.gz)
+depends=('perl-file-which' 'gcc-fortran')
+source=(http://search.cpan.org/CPAN/authors/id/K/KG/KGB/ExtUtils-F77-1.24.tar.gz)
options=(!emptydirs)
-md5sums=('df37ee4070908e55d038b2d26d27ef50')
+md5sums=('575fd322322c605718142bc6c4db034a')
sanitize() {
unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
@@ -20,21 +20,21 @@ sanitize() {
}
build() {
- cd ExtUtils-F77-1.20
+ cd ExtUtils-F77-1.24
sanitize
perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd ExtUtils-F77-1.20
+ cd ExtUtils-F77-1.24
sanitize
- F77LIBS='-lgfortran -lm' make test
+ make test
}
package() {
- cd ExtUtils-F77-1.20
+ cd ExtUtils-F77-1.24
sanitize
make install DESTDIR="$pkgdir"
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ find "$pkgdir" \( -name .packlist -o -name perllocal.pod \) -delete
}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
index 29a131206bbc..fa0a5f8e2f12 100644
--- a/PKGBUILD.tt
+++ b/PKGBUILD.tt
@@ -9,7 +9,7 @@ pkgdesc='Perl module providing simple interface to F77 libraries'
arch=('any')
url='[% url %]'
license=('PerlArtistic' 'GPL')
-depends=('perl' 'gcc-fortran')
+depends=('perl-file-which' 'gcc-fortran')
source=([% source %])
options=(!emptydirs)
md5sums=('[% md5sums %]')
@@ -29,12 +29,12 @@ build() {
check() {
cd [% distdir %]
sanitize
- F77LIBS='-lgfortran -lm' make test
+ make test
}
package() {
cd [% distdir %]
sanitize
make install DESTDIR="$pkgdir"
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ find "$pkgdir" \( -name .packlist -o -name perllocal.pod \) -delete
}