summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2015-08-12 08:12:14 +0300
committerAnton Leontiev2015-08-12 08:12:14 +0300
commite508319599ad949ed7e0649db1ef2585de83fefa (patch)
tree024b93e3f06630d6de8806b248b65faae04ae5ef
parent9a280ea9dc2a3431f6b48b415c1cc5e2346695be (diff)
downloadaur-e508319599ad949ed7e0649db1ef2585de83fefa.tar.gz
Updated to v1.18
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD28
-rw-r--r--PKGBUILD.tt10
3 files changed, 32 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index abecc69a8819..6c1ff7951dfa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = perl-extutils-f77
pkgdesc = Perl module providing simple interface to F77 libraries
- pkgver = 1.17
- pkgrel = 2
- url = http://search.cpan.org/dist/ExtUtils-F77
+ pkgver = 1.18
+ pkgrel = 1
+ url = https://metacpan.org/release/ExtUtils-F77
arch = any
license = PerlArtistic
license = GPL
depends = perl
depends = gcc-fortran
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/K/KG/KGB/ExtUtils-F77-1.17.tar.gz
- md5sums = c0143b5342587ed2ee5db3f6cfb9cc13
+ source = http://search.cpan.org/CPAN/authors/id/C/CH/CHM/ExtUtils-F77-1.18.tar.gz
+ md5sums = 7a9abbf3c68b96a44a2e0875a0663412
pkgname = perl-extutils-f77
diff --git a/PKGBUILD b/PKGBUILD
index 6bbc6ed8c515..db9bd9c45f5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,40 @@
# CPAN Name : ExtUtils::F77
# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
-# Generator : CPANPLUS::Dist::Arch 1.28
+# Generator : CPANPLUS::Dist::Arch 1.30
pkgname=perl-extutils-f77
-pkgver=1.17
-pkgrel=2
+pkgver=1.18
+pkgrel=1
pkgdesc='Perl module providing simple interface to F77 libraries'
arch=('any')
-url='http://search.cpan.org/dist/ExtUtils-F77'
+url='https://metacpan.org/release/ExtUtils-F77'
license=('PerlArtistic' 'GPL')
depends=('perl' 'gcc-fortran')
-source=(http://search.cpan.org/CPAN/authors/id/K/KG/KGB/ExtUtils-F77-1.17.tar.gz)
+source=(http://search.cpan.org/CPAN/authors/id/C/CH/CHM/ExtUtils-F77-1.18.tar.gz)
options=(!emptydirs)
-md5sums=('c0143b5342587ed2ee5db3f6cfb9cc13')
+md5sums=('7a9abbf3c68b96a44a2e0875a0663412')
+
+sanitize() {
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+}
build() {
- cd ExtUtils-F77-1.17
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ cd ExtUtils-F77-1.18
+ sanitize
+ perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd ExtUtils-F77-1.17
+ cd ExtUtils-F77-1.18
+ sanitize
F77LIBS='-lgfortran -lm' make test
}
package() {
- cd ExtUtils-F77-1.17
+ cd ExtUtils-F77-1.18
+ sanitize
make install DESTDIR="$pkgdir"
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
index 2fc9c74ddf6d..29a131206bbc 100644
--- a/PKGBUILD.tt
+++ b/PKGBUILD.tt
@@ -14,19 +14,27 @@ source=([% source %])
options=(!emptydirs)
md5sums=('[% md5sums %]')
+sanitize() {
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+}
+
build() {
cd [% distdir %]
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ sanitize
+ perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
cd [% distdir %]
+ sanitize
F77LIBS='-lgfortran -lm' make test
}
package() {
cd [% distdir %]
+ sanitize
make install DESTDIR="$pkgdir"
find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
}