summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Santiago2018-10-27 00:08:14 +0200
committerDavid Santiago2018-10-27 00:08:14 +0200
commit7ef93ebed4e1faf6d3cf11e3a3a1ba4038044b2d (patch)
tree42c2cb0dd56890ac7feb54dbd2585b1cdea21a0a
downloadaur-7ef93ebed4e1faf6d3cf11e3a3a1ba4038044b2d.tar.gz
First Release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8278a8d3202
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = perl-extutils-install
+ pkgdesc = ExtUtils::Install - install files from here to there
+ pkgver = 2.14
+ pkgrel = 1
+ url = https://metacpan.org/release/ExtUtils-Install
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl
+ options = !emptydirs
+ options = purge
+ source = https://cpan.metacpan.org/authors/id/B/BI/BINGOS/ExtUtils-Install-2.14.tar.gz
+ md5sums = ae6af2689daa6f8c2d01d04a28ab0ef0
+ sha512sums = 10f8b7e8bbd11c0860c9df72f8eb074eb329f889707788c7a1e81463022e4366173fa2681ddcb9c61514a075ddf3a63534a4758b47b259c84948bc633ddd78f5
+
+pkgname = perl-extutils-install
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1a97294ef968
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Contributor: Manifest0
+pkgname=perl-extutils-install
+pkgver=2.14
+pkgrel=1
+pkgdesc='ExtUtils::Install - install files from here to there'
+_dist='ExtUtils-Install'
+arch=('any')
+url="https://metacpan.org/release/$_dist"
+license=('GPL' 'PerlArtistic')
+depends=('perl')
+options=('!emptydirs' purge)
+source=("https://cpan.metacpan.org/authors/id/B/BI/BINGOS/$_dist-$pkgver.tar.gz")
+md5sums=('ae6af2689daa6f8c2d01d04a28ab0ef0')
+sha512sums=('10f8b7e8bbd11c0860c9df72f8eb074eb329f889707788c7a1e81463022e4366173fa2681ddcb9c61514a075ddf3a63534a4758b47b259c84948bc633ddd78f5')
+
+
+build() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ /usr/bin/perl Makefile.PL
+ make
+}
+
+check() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ make test
+}
+
+package() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+}