summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2015-06-14 16:06:21 +0200
committerPiotr Rogoża2015-06-14 16:06:21 +0200
commitaecd66bd672e4b56b79aff54d46ea6e50ef7de00 (patch)
tree233ec836034c3eae879ef52dbaeec8ecc5a31a75
downloadaur-aecd66bd672e4b56b79aff54d46ea6e50ef7de00.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD63
2 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7aba03ad56b3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = perl-file-find-rule-vcs
+ pkgdesc = File::Find::Rule::VCS - Exclude files/directories for Version Control Systems
+ pkgver = 1.08
+ pkgrel = 1
+ url = http://search.cpan.org/dist/File-Find-Rule-VCS/
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl>=5.10.0
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/File-Find-Rule-VCS-1.08.tar.gz
+ md5sums = 2e4031812450dc6510270cf88834d80c
+
+pkgname = perl-file-find-rule-vcs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99d7de893831
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# vim:set ts=2 sw=2 et ft=sh tw=100: expandtab
+# Maintainer: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+# Contributor: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+
+pkgname=perl-file-find-rule-vcs
+pkgver=1.08
+pkgrel=1
+_author="A/AD/ADAMK"
+_perlmod="File-Find-Rule-VCS"
+pkgdesc="File::Find::Rule::VCS - Exclude files/directories for Version Control Systems"
+arch=('any')
+url="http://search.cpan.org/dist/File-Find-Rule-VCS/"
+license=('GPL' 'PerlArtistic')
+depends=('perl>=5.10.0')
+options=(!emptydirs)
+source=("http://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz")
+
+build(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # Setting these env variables overwrites any command-line-options we don't want...
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ /usr/bin/perl Makefile.PL
+ make
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ /usr/bin/perl Build.PL
+ perl Build
+ fi
+}
+check(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make test
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build test
+ fi
+}
+package(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make install
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build install
+ fi
+
+ # remove perllocal.pod and .packlist
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+md5sums=('2e4031812450dc6510270cf88834d80c')