summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2017-04-20 17:04:28 -0600
committerJohn D Jones III2017-04-20 17:04:28 -0600
commitde4302024500b2c1a09f3a7742c9201687dcd795 (patch)
treee1136474f1bf0818d5e02c5fd78e38ce3ab356c6
downloadaur-de4302024500b2c1a09f3a7742c9201687dcd795.tar.gz
Add the Flickr::API
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD51
2 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9be2212804f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Thu Apr 20 23:04:09 UTC 2017
+pkgbase = perl-flickr-api
+ pkgdesc = Perl interface to the Flickr API
+ pkgver = 1.28
+ pkgrel = 1
+ url = https://metacpan.org/release/Flickr-API
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ checkdepends = perl-test-script
+ depends = perl-http-message>=1.56
+ depends = perl-net-oauth
+ depends = perl-uri>=1.18
+ depends = perl-xml-libxml-simple
+ depends = perl-xml-parser-lite-tree>=0.06
+ depends = perl-libwww
+ depends = perl>=5.008
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/L/LB/LBMOORE/Flickr-API-1.28.tar.gz
+ md5sums = 09f44555942d7c94410e20af60b9462d
+ sha512sums = 4d24f68fdb2e2b7805941333e160a5f1992c7816d7fba211637e94c18b1cf6c009729801bb2342cd5d897b13c1f37528932df7451369c005bbca8cc61f03f130
+
+pkgname = perl-flickr-api
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5ebe4118767
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Contributor: John D Jones III AKA jnbek <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+# Generator : CPANPLUS::Dist::Arch 1.32
+
+pkgname='perl-flickr-api'
+pkgver='1.28'
+pkgrel='1'
+pkgdesc="Perl interface to the Flickr API"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-http-message>=1.56' 'perl-net-oauth' 'perl-uri>=1.18' 'perl-xml-libxml-simple' 'perl-xml-parser-lite-tree>=0.06' 'perl-libwww' 'perl>=5.008')
+makedepends=()
+checkdepends=('perl-test-script')
+url='https://metacpan.org/release/Flickr-API'
+source=('http://search.cpan.org/CPAN/authors/id/L/LB/LBMOORE/Flickr-API-1.28.tar.gz')
+md5sums=('09f44555942d7c94410e20af60b9462d')
+sha512sums=('4d24f68fdb2e2b7805941333e160a5f1992c7816d7fba211637e94c18b1cf6c009729801bb2342cd5d897b13c1f37528932df7451369c005bbca8cc61f03f130')
+_distdir="Flickr-API-1.28"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: