summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArthur Țițeică2015-07-05 14:07:22 +0300
committerArthur Țițeică2015-07-05 14:07:22 +0300
commit1a353af2206010ee08a7e64557fcae4e4070b12c (patch)
tree4f78292d7a1c3202a3ada21726ed54d87ca7c656
downloadaur-1a353af2206010ee08a7e64557fcae4e4070b12c.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b99cadc2943
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = perl-geo-ipfree
+ pkgdesc = Look up country of IP Address. This module make this off-line and the DB of IPs is free & small.
+ pkgver = 1.141670
+ pkgrel = 1
+ url = http://search.cpan.org/~bricas/Geo-IPfree
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/B/BR/BRICAS/Geo-IPfree-1.141670.tar.gz
+ sha256sums = 7b67b200e0af839e6a7784ea309975d1c7ebf68fae56d5d7160193e2f360a772
+
+pkgname = perl-geo-ipfree
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75c0f926578b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Arthur Țițeică arthur.titeica/gmail/com
+# Contributor: Pizon <pizon@pizon.org>
+
+pkgname=perl-geo-ipfree
+pkgver=1.141670
+pkgrel=1
+pkgdesc="Look up country of IP Address. This module make this off-line and the DB of IPs is free & small."
+arch=('any')
+url="http://search.cpan.org/~bricas/Geo-IPfree"
+license=('GPL' 'PerlArtistic')
+options=('!emptydirs')
+source=(http://search.cpan.org/CPAN/authors/id/B/BR/BRICAS/Geo-IPfree-$pkgver.tar.gz)
+sha256sums=('7b67b200e0af839e6a7784ea309975d1c7ebf68fae56d5d7160193e2f360a772')
+
+build() {
+ cd "$srcdir/Geo-IPfree-$pkgver"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd "$srcdir/Geo-IPfree-$pkgver"
+ make install DESTDIR="$pkgdir/"
+ find "$pkgdir/" -name '.packlist' -delete
+ find "$pkgdir/" -name '*.pod' -delete
+}