summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzoe2017-01-29 09:34:37 +0100
committerzoe2017-01-29 09:34:37 +0100
commit6fe73cdc2313816fd8c3e419a9371a4134b8b343 (patch)
tree6cf385a00ea727312754ef131aa060bee066dedc
parentfdf51875e31b9e778e52cdec655417af19e54b4f (diff)
downloadaur-6fe73cdc2313816fd8c3e419a9371a4134b8b343.tar.gz
Update to 0.06-9
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD14
2 files changed, 10 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9762573a2b..7ab38a76fff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Jan 26 12:08:51 UTC 2017
+# Sun Jan 29 08:33:18 UTC 2017
pkgbase = perl-goo-canvas
pkgdesc = Perl bindings for GooCanvas
pkgver = 0.06
- pkgrel = 8
+ pkgrel = 9
url = http://search.cpan.org/dist/Goo-Canvas/
arch = i686
arch = x86_64
@@ -11,6 +11,7 @@ pkgbase = perl-goo-canvas
license = PerlArtistic
makedepends = perl-extutils-depends
makedepends = perl-extutils-pkgconfig
+ depends = perl
depends = cairo-perl
depends = glib-perl
depends = goocanvas1
@@ -20,10 +21,4 @@ pkgbase = perl-goo-canvas
md5sums = 7dfe0be8c17bfd641d18384d4fd8fb23
pkgname = perl-goo-canvas
- depends = cairo-perl
- depends = glib-perl
- depends = goocanvas1
- depends = gtk2-perl
- depends = perl>=
- depends = perl<
diff --git a/PKGBUILD b/PKGBUILD
index deed9fcf9ca..76ebee9126e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,12 +6,12 @@
pkgname=perl-goo-canvas
pkgver=0.06
-pkgrel=8
+pkgrel=9
pkgdesc="Perl bindings for GooCanvas"
arch=('i686' 'x86_64')
url="http://search.cpan.org/dist/Goo-Canvas/"
license=('GPL' 'PerlArtistic')
-depends=('cairo-perl' 'glib-perl' 'goocanvas1' 'gtk2-perl')
+depends=('perl' 'cairo-perl' 'glib-perl' 'goocanvas1' 'gtk2-perl')
makedepends=('perl-extutils-depends' 'perl-extutils-pkgconfig')
options=('!emptydirs')
source=("http://search.cpan.org/CPAN/authors/id/Y/YE/YEWENBIN/Goo-Canvas-$pkgver.tar.gz")
@@ -32,10 +32,10 @@ package() {
cd "$srcdir/Goo-Canvas-$pkgver"
make install DESTDIR="$pkgdir"
# template start; name=perl-binary-module-dependency; version=1;
-if [[ $(find "$pkgdir/usr/lib/perl5/" -name "*.so") ]]; then
- _perlver_min=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]);')
- _perlver_max=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]+1);')
- depends+=("perl>=$_perlver_min" "perl<$_perlver_max")
-fi
+#if [[ $(find "$pkgdir/usr/lib/perl5/" -name "*.so") ]]; then
+# _perlver_min=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]);')
+# _perlver_max=$(perl -e '$v = $^V->{version}; print $v->[0].".".($v->[1]+1);')
+# depends+=("perl>=$_perlver_min" "perl<$_perlver_max")
+#fi
# template end;
}