summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 15:00:12 -0600
committerJohn D Jones III2015-06-16 15:00:12 -0600
commitda28fd6aa4870cd6d2ae027646bd6136b98fcd52 (patch)
treef6089514c6f6660e27bb7743279c9fc6362100ba
downloadaur-da28fd6aa4870cd6d2ae027646bd6136b98fcd52.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD50
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7563de6d6e8f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-graph
+ pkgdesc = graph data structures and algorithms
+ pkgver = 0.96
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Graph
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/J/JH/JHI/Graph-0.96.tar.gz
+ md5sums = 24734ad5a6a20023f3950681f8e9b029
+ sha512sums = afcaa154473696e51310a9b0e1b1a48c29ce60fa3462d25c9fba1a5080a8205e2a734a6870a2d1770e3df88ffd5cde144861ea7ab794313df8c2a715e1540c67
+
+pkgname = perl-graph
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..063e5d6f994c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname='perl-graph'
+pkgver='0.96'
+pkgrel='1'
+pkgdesc="graph data structures and algorithms"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='http://search.cpan.org/dist/Graph'
+source=('http://search.cpan.org/CPAN/authors/id/J/JH/JHI/Graph-0.96.tar.gz')
+md5sums=('24734ad5a6a20023f3950681f8e9b029')
+sha512sums=('afcaa154473696e51310a9b0e1b1a48c29ce60fa3462d25c9fba1a5080a8205e2a734a6870a2d1770e3df88ffd5cde144861ea7ab794313df8c2a715e1540c67')
+_distdir="Graph-0.96"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: