summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoroli2015-06-12 22:01:14 +0200
committeroli2015-06-12 22:01:14 +0200
commit097090c35bca876e1d52384a0328989e16ed922d (patch)
treef4f55123e11ac4dc98d92667bd182068d14c930d
downloadaur-097090c35bca876e1d52384a0328989e16ed922d.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09c0514f1bd1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = perl-gtk2-sourceview2
+ pkgdesc = Perl interface to the GtkSourceView library
+ pkgver = 0.10
+ pkgrel = 4
+ url = http://search.cpan.org/~POTYL/Gtk2-SourceView2
+ arch = any
+ license = GPL
+ depends = gtksourceview2
+ depends = pango-perl
+ depends = gtk2-perl
+ depends = perl-extutils-depends
+ depends = perl-extutils-pkgconfig
+ options = !emptydirs
+ source = http://cpan.metacpan.org/authors/id/P/PO/POTYL/Gtk2-SourceView2-0.10.tar.gz
+ md5sums = 87e81e182fe013bb445f211e5e407029
+
+pkgname = perl-gtk2-sourceview2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec46cc0c4ad7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jose Riha <jose1711 gmail com>
+
+pkgname=perl-gtk2-sourceview2
+_cpanname=Gtk2-SourceView2
+pkgver=0.10
+pkgrel=4
+pkgdesc="Perl interface to the GtkSourceView library"
+arch=('any')
+url="http://search.cpan.org/~POTYL/${_cpanname}"
+license=('GPL')
+depends=('gtksourceview2' 'pango-perl' 'gtk2-perl' 'perl-extutils-depends' 'perl-extutils-pkgconfig')
+options=('!emptydirs')
+source=(http://cpan.metacpan.org/authors/id/P/PO/POTYL/${_cpanname}-${pkgver}.tar.gz)
+md5sums=('87e81e182fe013bb445f211e5e407029')
+
+build() {
+ cd $srcdir/${_cpanname}-${pkgver}
+ sed -i '/^auto_install/d' Makefile.PL
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd $srcdir/${_cpanname}-${pkgver}
+ make install DESTDIR=$pkgdir
+ find $pkgdir -name '.packlist' -delete
+ find $pkgdir -name '*.pod' -delete
+}