summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhoton892018-04-04 12:02:15 +0200
committerPhoton892018-04-04 12:02:15 +0200
commit2e7cacf58a85679bf2d8504caa33838511221c42 (patch)
tree253470849ab726c13a8d9b75095607648de91410
parentb7fc551b99febde8f46a9c5b9fffb50155e7f90e (diff)
downloadaur-2e7cacf58a85679bf2d8504caa33838511221c42.tar.gz
Added patch fixing crashes when a second instance of an app is launched
-rw-r--r--PKGBUILD12
-rw-r--r--fix_segfault_2nd_instance.patch13
2 files changed, 21 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 29678fcb6921..ce79edc8c37c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,12 @@
# Contributor: Crotok <crotok [at] mailbox [dot] org>
# Contributor: Felix Yan <felixonmars@archlinux.org>
# Contributor: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Michael Kogan <michael dot kogan at gmx dot net>
pkgname=perl-gtk2-unique
_cpanname=Gtk2-Unique
pkgver=0.05
-pkgrel=21
+pkgrel=22
pkgdesc="Perl bindings for the C library libunique"
arch=('i686' 'x86_64')
url="https://metacpan.org/release/${_cpanname}"
@@ -16,13 +17,16 @@ depends=('perl' 'gtk2-perl' 'libunique')
checkdepends=('xorg-server-xvfb')
options=('!emptydirs')
source=("http://search.cpan.org/CPAN/authors/id/P/PO/POTYL/${_cpanname}-${pkgver}.tar.gz"
- "$pkgname.patch")
+ "$pkgname.patch"
+ "fix_segfault_2nd_instance.patch")
md5sums=('0beb552933b765a017588563a71af123'
- 'f8e15e1b93e2629e1745f8e4de8524ff')
+ 'f8e15e1b93e2629e1745f8e4de8524ff'
+ 'b509a893e15c614dc668348c89e83c2d')
build() {
cd $_cpanname-$pkgver
patch -Np1 -i ../$pkgname.patch
+ patch -Np1 -i ../fix_segfault_2nd_instance.patch
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
sed -e 's,q(build/doc.pl),q(./build/doc.pl),g' -i Makefile
make
@@ -49,4 +53,4 @@ package() {
find "$pkgdir" -name '.packlist' -delete
find "$pkgdir" -name '*.pod' -delete
_perl_depends
-}
+} \ No newline at end of file
diff --git a/fix_segfault_2nd_instance.patch b/fix_segfault_2nd_instance.patch
new file mode 100644
index 000000000000..3a886c38c482
--- /dev/null
+++ b/fix_segfault_2nd_instance.patch
@@ -0,0 +1,13 @@
+Index: libgtk2-unique-perl/xs/UniqueApp.xs
+===================================================================
+--- libgtk2-unique-perl.orig/xs/UniqueApp.xs
++++ libgtk2-unique-perl/xs/UniqueApp.xs
+@@ -1,6 +1,8 @@
+ #include "unique-perl.h"
+ #include <gperl_marshal.h>
+
++G_CONST_RETURN gchar * unique_command_to_string (UniqueApp *app, gint command);
++
+ static void
+ perl_unique_app_marshall_message_received (
+ GClosure *closure,