summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorint2018-08-17 19:31:04 +0200
committerint2018-08-17 19:31:04 +0200
commitfd6ca36a091f606839799c2c349a48ec95f08130 (patch)
tree0e5e165a0ce1c34d2871b43494000613bbc47d31
parentd77ed88445fa685caa02a1862a7d7f3273a9f377 (diff)
downloadaur-fd6ca36a091f606839799c2c349a48ec95f08130.tar.gz
Version bump and new maintainer.
New maintainer, regenerated PKGBUILD via cpan2aur. The URL changed with the new version. I also changed the package description slightly and added this the cpan2aur-bugfix, see https://rt.cpan.org/Public/Bug/Display.html?id=123153 for details.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15263335f57d..0fcc04bc268d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = perl-hash-multivalue
- pkgdesc = Store multiple values per key
- pkgver = 0.15
+ pkgdesc = Perl/CPAN Module Hash::MultiValue: Store multiple values per key
+ pkgver = 0.16
pkgrel = 1
- url = http://search.cpan.org/dist/Hash-MultiValue
+ url = https://metacpan.org/release/Hash-MultiValue
arch = any
license = PerlArtistic
license = GPL
- depends = perl
+ depends = perl>=5.8.1
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/M/MI/MIYAGAWA/Hash-MultiValue-0.15.tar.gz
- md5sums = eb7df1402b774b07a305dbb67873817a
- sha512sums = fd97db887590c8c9ecbd0e58434df01fae8e3d2aa2335245ea1217d454e50c3bf1177921dd340f4cca3685808bebc573d13c892da7ccd685d3658c1db9d96465
+ source = http://search.cpan.org/CPAN/authors/id/A/AR/ARISTOTLE/Hash-MultiValue-0.16.tar.gz
+ md5sums = 508015312eb08cd2bcea987c4efbb93d
+ sha512sums = a6e1cab00ff24492bc84343b83a1282ad0eaded6633e7c511389dfb1d21cd8987dc2f1ad9ab69df69f36b651d68c70df3160666ff9ee584dbb1b6ab7095b78ac
pkgname = perl-hash-multivalue
diff --git a/PKGBUILD b/PKGBUILD
index f2a7a1910dd4..0f490487ddd6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,21 @@
+# Maintainer : int <int [ate] arcor [dot] de>
# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
-# Generator : CPANPLUS::Dist::Arch 1.25
+# Generator : CPANPLUS::Dist::Arch 1.32
pkgname='perl-hash-multivalue'
-pkgver='0.15'
+pkgver='0.16'
pkgrel='1'
-pkgdesc="Store multiple values per key"
+pkgdesc="Perl/CPAN Module Hash::MultiValue: Store multiple values per key"
arch=('any')
license=('PerlArtistic' 'GPL')
options=('!emptydirs')
-depends=('perl')
+depends=('perl>=5.8.1')
makedepends=()
-url='http://search.cpan.org/dist/Hash-MultiValue'
-source=('http://search.cpan.org/CPAN/authors/id/M/MI/MIYAGAWA/Hash-MultiValue-0.15.tar.gz')
-md5sums=('eb7df1402b774b07a305dbb67873817a')
-sha512sums=('fd97db887590c8c9ecbd0e58434df01fae8e3d2aa2335245ea1217d454e50c3bf1177921dd340f4cca3685808bebc573d13c892da7ccd685d3658c1db9d96465')
-_distdir="Hash-MultiValue-0.15"
+url='https://metacpan.org/release/Hash-MultiValue'
+source=("http://search.cpan.org/CPAN/authors/id/A/AR/ARISTOTLE/Hash-MultiValue-${pkgver}.tar.gz")
+md5sums=('508015312eb08cd2bcea987c4efbb93d')
+sha512sums=('a6e1cab00ff24492bc84343b83a1282ad0eaded6633e7c511389dfb1d21cd8987dc2f1ad9ab69df69f36b651d68c70df3160666ff9ee584dbb1b6ab7095b78ac')
+_distdir="Hash-MultiValue-${pkgver}"
build() {
( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
@@ -40,7 +41,7 @@ package() {
cd "$srcdir/$_distdir"
make install
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ find "$pkgdir" "(" -name .packlist -o -name perllocal.pod ")" -delete
}
# Local Variables: