summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRubenKelevra2016-07-05 15:50:41 +0200
committerRubenKelevra2016-07-05 15:50:41 +0200
commitf6e8f2040d7e7262210183da86328b723c805b00 (patch)
tree59d7f35eb501dcf4ea7821c69903e0fbb9ab5122
downloadaur-f6e8f2040d7e7262210183da86328b723c805b00.tar.gz
initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD46
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..edcee98d9ef6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Jul 5 13:50:30 UTC 2016
+pkgbase = perl-html-quoted
+ pkgdesc = Extract structure of quoted HTML mail message
+ pkgver = 0.03
+ pkgrel = 3
+ url = http://search.cpan.org/~ruz/HTML-Quoted
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl>=5.10.0
+ depends = perl-html-parser
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/R/RU/RUZ/HTML-Quoted-0.03.tar.gz
+ sha256sums = ec5eedcbbbf8fd0a91e95c2bf35fe6efe0e1faa4f64f18063b4c240c29d08175
+
+pkgname = perl-html-quoted
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3cf0abc3966f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Contributor: Maxwell Pray a.k.a. Synthead <synthead@gmail.com>
+# Maintainer: Ruben Kelevra <ruben@vfn-nrw.de
+
+pkgname=perl-html-quoted
+_cpanname="HTML-Quoted"
+pkgver=0.03
+pkgrel=3
+pkgdesc="Extract structure of quoted HTML mail message"
+arch=('any')
+url="http://search.cpan.org/~ruz/$_cpanname"
+license=('GPL' 'PerlArtistic')
+depends=('perl>=5.10.0' 'perl-html-parser')
+options=('!emptydirs')
+source=("http://search.cpan.org/CPAN/authors/id/R/RU/RUZ/$_cpanname-$pkgver.tar.gz")
+sha256sums=('ec5eedcbbbf8fd0a91e95c2bf35fe6efe0e1faa4f64f18063b4c240c29d08175')
+
+# Function to change to the working directory and set
+# environment variables to override undesired options.
+prepareEnvironment() {
+ cd "$srcdir/$_cpanname-$pkgver"
+ export \
+ PERL_MM_USE_DEFAULT=1 \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+}
+
+build() {
+ prepareEnvironment
+ /usr/bin/perl Makefile.PL
+ make
+}
+
+check() {
+ prepareEnvironment
+ make test
+}
+
+package() {
+ prepareEnvironment
+ make install
+
+ # Remove "perllocal.pod" and ".packlist".
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}