summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2015-06-29 19:03:36 +0200
committerChristian Hesse2015-06-29 19:03:36 +0200
commitdef5311414617b0ee8baf69789a6fd85a2873f62 (patch)
tree024c52a624c6d4608b77a601ff43b95dd0a4e974
downloadaur-def5311414617b0ee8baf69789a6fd85a2873f62.tar.gz
initial import of perl-html-simpleparse 0.12-3
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..69572116a241
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = perl-html-simpleparse
+ pkgdesc = Perl/CPAN Module HTML::SimpleParse - a bare-bones HTML parser.
+ pkgver = 0.12
+ pkgrel = 3
+ url = http://search.cpan.org/dist/HTML-SimpleParse/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = PerlArtistic
+ depends = perl>=5.10.0
+ provides = html-simpleparse
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/K/KW/KWILLIAMS/HTML-SimpleParse-0.12.tar.gz
+ sha256sums = c103a19cf99801489ce23e4da86a5f9df79f032f1f1c71b8130d0d3ff96e6304
+
+pkgname = perl-html-simpleparse
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f63857bd3834
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: BinkyTheClown <binky_at_archlinux_dot_us>
+# PKGBUILD generated by pacpan -mostly-
+
+pkgname=perl-html-simpleparse
+_realname=HTML-SimpleParse
+pkgver=0.12
+pkgrel=3
+pkgdesc="Perl/CPAN Module HTML::SimpleParse - a bare-bones HTML parser."
+arch=(i686 x86_64)
+url="http://search.cpan.org/dist/${_realname}/"
+license=('GPL' 'PerlArtistic')
+depends=('perl>=5.10.0')
+options=(!emptydirs)
+provides=('html-simpleparse')
+source=("http://search.cpan.org/CPAN/authors/id/K/KW/KWILLIAMS/${_realname}-${pkgver}.tar.gz")
+sha256sums=('c103a19cf99801489ce23e4da86a5f9df79f032f1f1c71b8130d0d3ff96e6304')
+
+build() {
+ cd ${srcdir}/${_realname}-${pkgver}
+
+ # install module in vendor directories.
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+package() {
+ cd ${srcdir}/${_realname}-${pkgver}
+
+ make install DESTDIR=${pkgdir}
+
+ # remove perllocal.pod and .packlist
+ find ${pkgdir} -name perllocal.pod -delete
+ find ${pkgdir} -name .packlist -delete
+}
+