summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPappy STĂNESCU2016-10-03 18:31:36 +0300
committerPappy STĂNESCU2016-10-03 18:31:36 +0300
commit9bdb0f45f13c31887c005de822167b289949967b (patch)
tree7741e90285901a23335e56418aa51b8f8a1bdd9e
downloadaur-9bdb0f45f13c31887c005de822167b289949967b.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD36
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..48c56c98224d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = perl-http-server-simple-static
+ pkgdesc = Serve static files with HTTP::Server::Simple
+ pkgver = 0.12
+ pkgrel = 1
+ url = http://search.cpan.org/~sjquinney/HTTP-Server-Simple-Static-0.12
+ arch = any
+ depends = perl-http-server-simple
+ depends = perl-http-date
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/S/SJ/SJQUINNEY/HTTP-Server-Simple-Static-0.12.tar.gz
+ md5sums = 4ef0085b300a1e001b76b484d724e0d3
+
+pkgname = perl-http-server-simple-static
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b5624b74f804
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf591c22224e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Pappy STĂNESCU <pappy _AT_ a s c e l i o n _DOT_ com>
+
+_cpan_name=HTTP-Server-Simple-Static
+_cpan_desc='Serve static files with HTTP::Server::Simple'
+_cpan_author=sjquinney
+_cpan_version=0.12
+_cpan_md5=4ef0085b300a1e001b76b484d724e0d3
+
+pkgrel=1
+pkgname=perl-${_cpan_name,,}
+pkgdesc=$_cpan_desc
+pkgver=$_cpan_version
+md5sums=($_cpan_md5)
+depends=('perl-http-server-simple' 'perl-http-date')
+makedepends=('')
+checkdepends=()
+
+_cpan_path=${_cpan_author:0:1}/${_cpan_author:0:2}/${_cpan_author}
+
+url="http://search.cpan.org/~${_cpan_author}/${_cpan_name}-$pkgver"
+source=("http://search.cpan.org/CPAN/authors/id/${_cpan_path^^}/${_cpan_name}-$pkgver.tar.gz")
+options=(!emptydirs)
+arch=('any')
+
+build() {
+ cd $srcdir/${_cpan_name}-$pkgver
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+ make test
+}
+
+package() {
+ cd $srcdir/${_cpan_name}-$pkgver
+ make install DESTDIR=$pkgdir
+}
+