summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 11:05:54 -0600
committerBrian Bidulock2015-06-10 11:05:54 -0600
commit2b1e2cf85317b8762266063dc7b6673bdd030a3e (patch)
treee3554f511325fe0644954cebc2e7696b5039ad68
downloadaur-2b1e2cf85317b8762266063dc7b6673bdd030a3e.tar.gz
initial version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d5d645c0042e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = perl-image-base-x11-protocol
+ pkgdesc = Draw into an X11::Protocol
+ pkgver = 14
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Image-Base-X11-Protocol/
+ arch = any
+ license = GPL
+ depends = perl-x11-protocol-other
+ depends = perl-image-base
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/K/KR/KRYDE/Image-Base-X11-Protocol-14.tar.gz
+ sha256sums = a248d66d43965779d8b44fb6e5e679706c124d6b762cd91108e6f1b46d5e4bed
+
+pkgname = perl-image-base-x11-protocol
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42f26bab8e1f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+
+pkgname=perl-image-base-x11-protocol
+_lastauthor=K/KR/KRYDE
+_pkgname=Image-Base-X11-Protocol
+pkgver=14
+pkgrel=1
+pkgdesc="Draw into an X11::Protocol"
+arch=('any')
+license=('GPL')
+options=('!emptydirs')
+depends=('perl-x11-protocol-other' 'perl-image-base')
+url="http://search.cpan.org/dist/${_pkgname}/"
+source=(http://search.cpan.org/CPAN/authors/id/${_lastauthor}/${_pkgname}-${pkgver}.tar.gz)
+sha256sums=('a248d66d43965779d8b44fb6e5e679706c124d6b762cd91108e6f1b46d5e4bed')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+check() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ make test
+}
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ make DESTDIR="$pkgdir" install
+}