summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Ober2017-09-04 13:34:23 +0200
committerMax Ober2017-09-04 13:34:23 +0200
commit7a77a0a259c2dd32d405e6e6aeb5d3b1acf9a908 (patch)
tree0293a06207d8a6856113c24bb6068d9944011798
downloadaur-7a77a0a259c2dd32d405e6e6aeb5d3b1acf9a908.tar.gz
initial
-rw-r--r--.SRCINFO24
-rw-r--r--430805.patch10
-rw-r--r--58454.patch20
-rw-r--r--Image-LibRSVG-0.07.tar.gzbin0 -> 111136 bytes
-rw-r--r--PKGBUILD48
-rw-r--r--disableCompressionSupported.patch10
6 files changed, 112 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..255c62c940bd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = perl-image-librsvg
+ pkgdesc = This packages the SMBus distribution, containing the Device::SMBus module!
+ pkgver = 0.07
+ pkgrel = 1
+ url = https://metacpan.org/release/Image-LibRSVG
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl
+ depends = librsvg
+ depends = zlib
+ options = !emptydirs
+ options = purge
+ source = http://search.cpan.org/CPAN/authors/id/T/TO/TOMSON/Image-LibRSVG-0.07.tar.gz
+ source = https://rt.cpan.org/Ticket/Attachment/342021/153391/430805.patch
+ source = 58454.patch
+ source = disableCompressionSupported.patch
+ md5sums = 43bcff1a9994ed5e184d44e49d2bd7fa
+ md5sums = fcb2f5dc83573e23833bed6295f0a2b9
+ md5sums = ecaf769fc88f4f6b48891e2b3a17c156
+ md5sums = 2f4b436a5047a5cb1d9a0520909cc622
+
+pkgname = perl-image-librsvg
+
diff --git a/430805.patch b/430805.patch
new file mode 100644
index 000000000000..2f620896decc
--- /dev/null
+++ b/430805.patch
@@ -0,0 +1,10 @@
+--- LibRSVG.xs 2007/07/03 07:05:37 1.1
++++ LibRSVG.xs 2007/07/03 07:05:52
+@@ -383,6 +383,7 @@
+ CODE:
+ Newz(0, RETVAL, 1, SVGLibRSVG);
+ RETVAL->pixbuf = NULL;
++ rsvg_init();
+ OUTPUT:
+ RETVAL
+
diff --git a/58454.patch b/58454.patch
new file mode 100644
index 000000000000..0459e89fa31b
--- /dev/null
+++ b/58454.patch
@@ -0,0 +1,20 @@
+--- lib/Image/LibRSVG.pm 2017-09-04 13:05:56.696354975 +0200
++++ lib/Image/LibRSVG.pm 2017-09-04 13:06:22.226421571 +0200
+@@ -53,7 +53,7 @@
+ $rv = $self->loadFromFile( $file_path );
+ } elsif ( $args->{zoom} ) {
+ $rv = $self->loadFromFileAtZoom( $file_path, $args->{zoom}->[0], $args->{zoom}->[1], $dpi );
+- } elsif( $args->{dimesion} ) {
++ } elsif( $args->{dimension} ) {
+ if( defined $args->{dimension}->[2] && $args->{dimension}->[2] ) {
+ $rv = $self->loadFromFileAtMaxSize( $file_path, $args->{dimension}->[0], $args->{dimension}->[1], $dpi );
+ } else {
+@@ -78,7 +78,7 @@
+ $rv = $self->loadFromString( $file_path );
+ } elsif ( $args->{zoom} ) {
+ $rv = $self->loadFromStringAtZoom( $file_path, $args->{zoom}->[0], $args->{zoom}->[1], $dpi );
+- } elsif( $args->{dimesion} ) {
++ } elsif( $args->{dimension} ) {
+ if( defined $args->{dimension}->[2] && $args->{dimension}->[2] ) {
+ $rv = $self->loadFromStringAtMaxSize( $file_path, $args->{dimension}->[0], $args->{dimension}->[1], $dpi );
+ } else {
diff --git a/Image-LibRSVG-0.07.tar.gz b/Image-LibRSVG-0.07.tar.gz
new file mode 100644
index 000000000000..2af950bb778a
--- /dev/null
+++ b/Image-LibRSVG-0.07.tar.gz
Binary files differ
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d59560a7792f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Contributor: mober <maxATmoberDOTat>
+
+pkgname=perl-image-librsvg
+pkgver=0.07
+pkgrel=1
+pkgdesc='This packages the SMBus distribution, containing the Device::SMBus module!'
+_dist=Image-LibRSVG
+arch=('any')
+url="https://metacpan.org/release/$_dist"
+license=('GPL' 'PerlArtistic')
+depends=('perl' 'librsvg' 'zlib')
+options=('!emptydirs' purge)
+source=("http://search.cpan.org/CPAN/authors/id/T/TO/TOMSON/$_dist-$pkgver.tar.gz"
+ "https://rt.cpan.org/Ticket/Attachment/342021/153391/430805.patch"
+ "58454.patch"
+ "disableCompressionSupported.patch")
+md5sums=('43bcff1a9994ed5e184d44e49d2bd7fa'
+ 'fcb2f5dc83573e23833bed6295f0a2b9'
+ 'ecaf769fc88f4f6b48891e2b3a17c156'
+ '2f4b436a5047a5cb1d9a0520909cc622')
+
+prepare() {
+ cd "$srcdir/$_dist-$pkgver"
+ patch -Np0 -i "${srcdir}/430805.patch"
+ patch -Np0 -i "${srcdir}/58454.patch"
+ patch -Np0 -i "${srcdir}/disableCompressionSupported.patch"
+}
+
+build() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ /usr/bin/perl Makefile.PL
+ make
+}
+
+check() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ make test
+}
+
+package() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+}
diff --git a/disableCompressionSupported.patch b/disableCompressionSupported.patch
new file mode 100644
index 000000000000..a77004f5476b
--- /dev/null
+++ b/disableCompressionSupported.patch
@@ -0,0 +1,10 @@
+--- LibRSVG.xs 2017-09-04 13:22:45.369221170 +0200
++++ LibRSVG.xs 2017-09-04 13:25:11.239629553 +0200
+@@ -456,7 +456,7 @@
+ static bool
+ SVGLibRSVG::isGzCompressionSupported()
+ CODE:
+- RETVAL = 1;
++ RETVAL = 0;
+ OUTPUT:
+ RETVAL