summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 15:09:24 -0600
committerJohn D Jones III2015-06-16 15:09:24 -0600
commitc158cd3d05cda4c8c07b1432226a120a2a2addcb (patch)
treef6d7c656978c270bc2e3855bfe2067f789cf7e62
downloadaur-c158cd3d05cda4c8c07b1432226a120a2a2addcb.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD50
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..476497ba791a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = perl-indirect
+ pkgdesc = Lexically warn about using the indirect method call syntax.
+ pkgver = 0.33
+ pkgrel = 1
+ url = http://search.mcpan.org/dist/indirect
+ arch = i686
+ arch = x86_64
+ license = PerlArtistic
+ license = GPL
+ depends = perl>=5.8.1
+ options = !emptydirs
+ source = http://search.mcpan.org/CPAN/authors/id/V/VP/VPIT/indirect-0.33.tar.gz
+ md5sums = 3a8c66e97f46120ff44023ee295d5acb
+ sha512sums = 3cee58c3e14e6eb896916ffacef20ad41d66ed433fe0419c93eaf524db5ddfda628697241b2e8ae021835921ffc62b9db7df5e22a1465311e252de80c9e14e91
+
+pkgname = perl-indirect
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c31c0341c6f2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+# Generator : CPANPLUS::Dist::Arch 1.29
+
+pkgname='perl-indirect'
+pkgver='0.33'
+pkgrel='1'
+pkgdesc="Lexically warn about using the indirect method call syntax."
+arch=('i686' 'x86_64')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl>=5.8.1')
+makedepends=()
+url='http://search.mcpan.org/dist/indirect'
+source=('http://search.mcpan.org/CPAN/authors/id/V/VP/VPIT/indirect-0.33.tar.gz')
+md5sums=('3a8c66e97f46120ff44023ee295d5acb')
+sha512sums=('3cee58c3e14e6eb896916ffacef20ad41d66ed433fe0419c93eaf524db5ddfda628697241b2e8ae021835921ffc62b9db7df5e22a1465311e252de80c9e14e91')
+_distdir="indirect-0.33"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: