summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2015-02-14 18:22:52 +0300
committerAnton Leontiev2015-02-15 07:48:24 +0300
commitfb4bc92e5728773ed5faeeb77566375571d8c10f (patch)
tree8e366e9f93d50f4b06e67508585e0a8c829b638a
downloadaur-fb4bc92e5728773ed5faeeb77566375571d8c10f.tar.gz
Initial v0.73
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD48
-rw-r--r--PKGBUILD.tt48
4 files changed, 126 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..69e8c2fc2dc9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = perl-inline-c
+ pkgdesc = Perl module providing a way to write Perl subroutines in C
+ pkgver = 0.73
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Inline-C
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ checkdepends = perl>=5.10.1
+ checkdepends = perl-file-copy-recursive
+ checkdepends = perl-io-all
+ checkdepends = perl-test-warn>=0.23
+ checkdepends = perl-yaml-libyaml
+ depends = perl>=5.5.4
+ depends = perl-inline>=0.77
+ depends = perl-parse-recdescent>=1.80
+ depends = perl-extutils-makemaker-aur>=7.00
+ depends = perl-pegex>=0.55
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/I/IN/INGY/Inline-C-0.73.tar.gz
+ md5sums = fb9a7dc92b959ab023838357767a5251
+
+pkgname = perl-inline-c
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e6b6b4b8077d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.lz
+src/
+pkg/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..183df21a8fe7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# CPAN Name : Inline::C
+# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
+# Generator : CPANPLUS::Dist::Arch 1.29
+
+pkgname=perl-inline-c
+pkgver=0.73
+pkgrel=1
+pkgdesc='Perl module providing a way to write Perl subroutines in C'
+arch=('any')
+url='http://search.cpan.org/dist/Inline-C'
+license=('PerlArtistic' 'GPL')
+options=(!emptydirs)
+depends=(
+ 'perl>=5.5.4'
+ 'perl-inline>=0.77'
+ 'perl-parse-recdescent>=1.80'
+ 'perl-extutils-makemaker-aur>=7.00'
+ 'perl-pegex>=0.55')
+checkdepends=(
+ 'perl>=5.10.1'
+ 'perl-file-copy-recursive'
+ 'perl-io-all'
+ 'perl-test-warn>=0.23'
+ 'perl-yaml-libyaml')
+source=(http://search.cpan.org/CPAN/authors/id/I/IN/INGY/Inline-C-0.73.tar.gz)
+md5sums=('fb9a7dc92b959ab023838357767a5251')
+
+build() {
+ cd Inline-C-0.73
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ /usr/bin/perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd Inline-C-0.73
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ make test
+}
+
+package() {
+ cd Inline-C-0.73
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
new file mode 100644
index 000000000000..a9e0a45aeb39
--- /dev/null
+++ b/PKGBUILD.tt
@@ -0,0 +1,48 @@
+# CPAN Name : Inline::C
+# Contributor: [% packager %]
+# Generator : CPANPLUS::Dist::Arch [% version %]
+
+pkgname=[% pkgname %]
+pkgver=[% pkgver %]
+pkgrel=[% pkgrel %]
+pkgdesc='Perl module providing a way to write Perl subroutines in C'
+arch=('any')
+url='[% url %]'
+license=('PerlArtistic' 'GPL')
+options=(!emptydirs)
+depends=(
+ 'perl>=5.5.4'
+ 'perl-inline>=0.77'
+ 'perl-parse-recdescent>=1.80'
+ 'perl-extutils-makemaker-aur>=7.00'
+ 'perl-pegex>=0.55')
+checkdepends=(
+ 'perl>=5.10.1'
+ 'perl-file-copy-recursive'
+ 'perl-io-all'
+ 'perl-test-warn>=0.23'
+ 'perl-yaml-libyaml')
+source=([% source %])
+md5sums=('[% md5sums %]')
+
+build() {
+ cd [% distdir %]
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ /usr/bin/perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd [% distdir %]
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ make test
+}
+
+package() {
+ cd [% distdir %]
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}