summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlithery2015-06-07 08:36:51 +0100
committerSlithery2015-06-07 08:36:51 +0100
commitc1f332baab118698008f40d66031c08c25609a90 (patch)
treebe3ab192a2c100849144bcbdff686fae93919ee6
downloadaur-c1f332baab118698008f40d66031c08c25609a90.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8348303e18df
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-io-lockedfile
+ pkgdesc = Supply object methods for locking files.
+ pkgver = 0.23
+ pkgrel = 2
+ url = https://metacpan.org/release/IO-LockedFile
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl
+ options = !emptydirs
+ options = purge
+ source = https://cpan.metacpan.org/authors/id/R/RA/RANI/IO-LockedFile-0.23.tar.gz
+ sha256sums = b1db7e6a6bf1be1e0615a6ecb5cebe78b00e287b127d5856d3f16b35dd47f8b5
+
+pkgname = perl-io-lockedfile
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad007806e763
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Slithery <aur at slithery dot uk>
+
+pkgname=perl-io-lockedfile
+pkgver=0.23
+pkgrel=2
+pkgdesc="Supply object methods for locking files."
+_dist=IO-LockedFile
+arch=('any')
+url="https://metacpan.org/release/$_dist"
+license=('GPL' 'PerlArtistic')
+depends=(perl)
+options=('!emptydirs' purge)
+source=("https://cpan.metacpan.org/authors/id/R/RA/RANI/$_dist-$pkgver.tar.gz")
+sha256sums=('b1db7e6a6bf1be1e0615a6ecb5cebe78b00e287b127d5856d3f16b35dd47f8b5')
+
+build() (
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ /usr/bin/perl Makefile.PL
+ make
+)
+
+check() (
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ make test
+)
+
+package() (
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+)