summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2015-06-14 16:06:54 +0200
committerPiotr Rogoża2015-06-14 16:06:54 +0200
commitee812d4e6879530d52dea7217520758738a436f6 (patch)
tree4440b00b9a7162164413c17e437d5d166b9f5557
downloadaur-ee812d4e6879530d52dea7217520758738a436f6.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD68
2 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd942d9f6cd9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-io-prompt-tiny
+ pkgdesc = IO::Prompt::Tiny - Prompt for user input with a default option
+ pkgver = 0.002
+ pkgrel = 1
+ url = http://search.cpan.org/dist/IO-Prompt-Tiny/
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ makedepends = perl-capture-tiny
+ depends = perl-capture-tiny
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/D/DA/DAGOLDEN/IO-Prompt-Tiny-0.002.tar.gz
+ md5sums = 1061da5fdc18084d1cf3c4c9a8fe2f88
+
+pkgname = perl-io-prompt-tiny
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a416d33e3c93
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# vim:set ts=2 sw=2 et ft=sh tw=100: expandtab
+# Maintainer: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+# Contributor: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+
+pkgname=perl-io-prompt-tiny
+pkgver=0.002
+pkgrel=1
+_author="D/DA/DAGOLDEN"
+_perlmod="IO-Prompt-Tiny"
+pkgdesc="IO::Prompt::Tiny - Prompt for user input with a default option"
+arch=('any')
+url="http://search.cpan.org/dist/IO-Prompt-Tiny/"
+license=('GPL' 'PerlArtistic')
+depends=(
+perl-capture-tiny
+)
+makedepends=(
+perl-capture-tiny
+)
+options=(!emptydirs)
+source=("http://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz")
+
+build(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # Setting these env variables overwrites any command-line-options we don't want...
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ /usr/bin/perl Makefile.PL
+ make
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ /usr/bin/perl Build.PL
+ perl Build
+ fi
+}
+check(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make test
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build test
+ fi
+}
+package(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make install
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build install
+ fi
+
+ # remove perllocal.pod and .packlist
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+md5sums=('1061da5fdc18084d1cf3c4c9a8fe2f88')