summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engeström2015-06-08 20:43:40 +0200
committerEric Engeström2015-06-08 20:48:38 +0200
commite27615ba6e81384ac8128cdf5eb83e6f2fea2ac8 (patch)
tree2be850f67299aefe54ea2a24dd1cfc61582609d1
downloadaur-e27615ba6e81384ac8128cdf5eb83e6f2fea2ac8.tar.gz
initial commit - v0.09-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD47
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c15b34995508
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by makepkg 4.2.1
+# Mon Jun 8 18:47:51 UTC 2015
+pkgbase = perl-io-pty-easy
+ pkgdesc = Easy interface to IO::Pty
+ pkgver = 0.09
+ pkgrel = 1
+ url = http://search.cpan.org/dist/IO-Pty-Easy
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl-io-tty
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/D/DO/DOY/IO-Pty-Easy-0.09.tar.gz
+ md5sums = 7950e652896adf85067753799232caf1
+
+pkgname = perl-io-pty-easy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cd7d1ba25c29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Contributor: Natal Ngétal <hobbestigrou@erakis.im>
+# Generator : CPANPLUS::Dist::Arch 1.19
+
+pkgname=perl-io-pty-easy
+pkgver=0.09
+pkgrel=1
+pkgdesc="Easy interface to IO::Pty"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl-io-tty')
+makedepends=()
+url='http://search.cpan.org/dist/IO-Pty-Easy'
+source=("http://search.cpan.org/CPAN/authors/id/D/DO/DOY/IO-Pty-Easy-${pkgver}.tar.gz")
+md5sums=('7950e652896adf85067753799232caf1')
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "${srcdir}/IO-Pty-Easy-${pkgver}"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "${srcdir}/IO-Pty-Easy-${pkgver}"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "${srcdir}/IO-Pty-Easy-${pkgver}"
+ make install
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: