summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 15:10:54 -0600
committerJohn D Jones III2015-06-16 15:10:54 -0600
commit7b4458b6bad0e78f7c55362ed3ce2cbd85c82036 (patch)
tree869dc68ac6eda8becaf9f273e11e86dc7e02d205
downloadaur-7b4458b6bad0e78f7c55362ed3ce2cbd85c82036.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD50
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bd190b7d1a30
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-io-util
+ pkgdesc = A selection of general-utility IO function
+ pkgver = 1.5
+ pkgrel = 1
+ url = http://search.cpan.org/dist/IO-Util
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/D/DO/DOMIZIO/IO-Util-1.5.tar.gz
+ md5sums = 520ce0056f3e5816ae82bc93bf413507
+ sha512sums = 5936241cdab8d601523efe1f2e9d3c7b3a99e46f59eb9a1ea7d273f2c1d36c6bdc75d2c5483d36f65e498384756a59adc0ba82a50bb4d7c34d5c73d52faa8867
+
+pkgname = perl-io-util
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a981eca9387a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname='perl-io-util'
+pkgver='1.5'
+pkgrel='1'
+pkgdesc="A selection of general-utility IO function"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='http://search.cpan.org/dist/IO-Util'
+source=('http://search.cpan.org/CPAN/authors/id/D/DO/DOMIZIO/IO-Util-1.5.tar.gz')
+md5sums=('520ce0056f3e5816ae82bc93bf413507')
+sha512sums=('5936241cdab8d601523efe1f2e9d3c7b3a99e46f59eb9a1ea7d273f2c1d36c6bdc75d2c5483d36f65e498384756a59adc0ba82a50bb4d7c34d5c73d52faa8867')
+_distdir="IO-Util-1.5"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: