summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2013-08-23 16:58:29 +0400
committerAnton Leontiev2015-02-15 07:48:01 +0300
commitaa5ca4574bdbaa36965f5d9f625c1e9a93eb9223 (patch)
treec3ad4a1f4b18ad7becb06377fafd7954306e9aea
downloadaur-aa5ca4574bdbaa36965f5d9f625c1e9a93eb9223.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD32
-rw-r--r--PKGBUILD.tt32
4 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e2063cba332
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = perl-ipc-pubsub
+ pkgdesc = Perl module providing a simple API for publishing messages to channels and for subscribing to them
+ pkgver = 0.29
+ pkgrel = 1
+ url = http://search.cpan.org/dist/IPC-PubSub
+ arch = any
+ license = MIT
+ depends = perl>=5.6.0
+ depends = perl-data-uuid
+ depends = perl-dbm-deep>=1.00
+ depends = perl-class-accessor
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/A/AL/ALEXMV/IPC-PubSub-0.29.tar.gz
+ md5sums = e10d5732307982eff46a4223f05d104f
+
+pkgname = perl-ipc-pubsub
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e6b6b4b8077d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.lz
+src/
+pkg/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..171b823326eb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# CPAN Name : IPC::PubSub
+# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
+# Generator : CPANPLUS::Dist::Arch 1.13
+
+pkgname=perl-ipc-pubsub
+pkgver=0.29
+pkgrel=1
+pkgdesc="Perl module providing a simple API for publishing messages to channels and for subscribing to them"
+arch=("any")
+url="http://search.cpan.org/dist/IPC-PubSub"
+license=("MIT")
+depends=("perl>=5.6.0" "perl-data-uuid" "perl-dbm-deep>=1.00" "perl-class-accessor")
+source=(http://search.cpan.org/CPAN/authors/id/A/AL/ALEXMV/IPC-PubSub-0.29.tar.gz)
+options=(!emptydirs)
+md5sums=("e10d5732307982eff46a4223f05d104f")
+
+build() {
+ cd "$srcdir/IPC-PubSub-0.29"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$srcdir/IPC-PubSub-0.29"
+ make test
+}
+
+package() {
+ cd "$srcdir/IPC-PubSub-0.29"
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
new file mode 100644
index 000000000000..b1d8def281c6
--- /dev/null
+++ b/PKGBUILD.tt
@@ -0,0 +1,32 @@
+# CPAN Name : IPC::PubSub
+# Contributor: [% packager %]
+# Generator : CPANPLUS::Dist::Arch [% version %]
+
+pkgname=[% pkgname %]
+pkgver=[% pkgver %]
+pkgrel=[% pkgrel %]
+pkgdesc="Perl module providing a simple API for publishing messages to channels and for subscribing to them"
+arch=("any")
+url="[% url %]"
+license=("MIT")
+depends=("perl>=5.6.0" "perl-data-uuid" "perl-dbm-deep>=1.00" "perl-class-accessor")
+source=([% source %])
+options=(!emptydirs)
+md5sums=("[% md5sums %]")
+
+build() {
+ cd "$srcdir/[% distdir %]"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd "$srcdir/[% distdir %]"
+ make test
+}
+
+package() {
+ cd "$srcdir/[% distdir %]"
+ make install DESTDIR="$pkgdir"
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}