summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnthony Cozamanis2015-11-03 09:54:57 +0800
committerAnthony Cozamanis2015-11-03 09:54:57 +0800
commitb2d6a065455350e0a1f294ca20ee6b47e5dd6da6 (patch)
tree6d5ce6c6168369c4b01515d44f4c6cf3cc5bc89e
downloadaur-b2d6a065455350e0a1f294ca20ee6b47e5dd6da6.tar.gz
Version update
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4522b6744655
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = perl-iptables-chainmgr
+ pkgdesc = IPTables::ChainMgr - Perl extension for manipulating iptables and ip6tables policies
+ pkgver = 1.4
+ pkgrel = 0
+ url = http://search.cpan.org/~mrash/IPTables-ChainMgr/
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl
+ depends = iptables
+ depends = perl-iptables-parse
+ depends = perl-netaddr-ip
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/M/MR/MRASH/IPTables-ChainMgr-1.4.tar.gz
+ md5sums = f322a583ef49c82c0807237542ed5f35
+
+pkgname = perl-iptables-chainmgr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..924440157918
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Contributor: Anthony C <kurodroid.1@gmail.com>
+
+pkgname=perl-iptables-chainmgr
+_pkgname=IPTables-ChainMgr
+pkgver=1.4
+pkgrel=0
+pkgdesc="IPTables::ChainMgr - Perl extension for manipulating iptables and ip6tables policies"
+arch=('any')
+url="http://search.cpan.org/~mrash/IPTables-ChainMgr/"
+license=('GPL' 'PerlArtistic')
+depends=('perl' 'iptables' 'perl-iptables-parse' 'perl-netaddr-ip')
+options=('!emptydirs')
+source=(http://search.cpan.org/CPAN/authors/id/M/MR/MRASH/$_pkgname-$pkgver.tar.gz)
+md5sums=('f322a583ef49c82c0807237542ed5f35')
+
+build() {
+ cd $_pkgname-$pkgver
+ perl Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ cd $_pkgname-$pkgver
+ make test
+}
+
+package() {
+ cd $_pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+